Servers by jDrones

Flip on take off after Chibios latest stable 3.6RC10 upgrade

(Hugues) #1

Hello,

I upgraded my octoquad (X8 config, 15" props, Pixhawk1, external GPS+compass) from arducopter/Nutx version 3.3 to the latest Chibios 3.6.
Nothing else changed or was modified.
In the Nutx 3.3 version, the ship fly wonderfully in all modes. Never had an issue.

After upgrading to Chibios 3.6 (latest stable release from mission planner), I redid the usual : compass, accel, radio, battery monitoring calibration (incl compassmot).
I did not recalibrate the ESCs as it should not be necessary (or am I wrong ?)

Then at first manually controlled take off (in stabilize mode), the drone flipped (rolled to the right) upside down (Breaking all of the props of course).
I looked at the log but could not find any issue or explanations. I rechecked after the crash the way the props were mounted to verify if any props was inverted. All props were correctly installed and no motor or mounts were defective.
So i really do not know what happened here and I would like the help of the Community to analyze what happened.
Attached the log of the incident
Thanks
2019-08-14 11-16-58.bin (263.1 KB)

(Mike Boland) #2

If you have a look at the motor outputs its shows the right motors peaking and the left shutting down.


This should have produced a roll to the left.
Motor order?
Have you checked the motor out mapping in MP?

1 Like
(Dave) #3

You have the Frame Class configured as Octa (3). Octaquad (X8) is 4.

1 Like
(Hugues) #4

Thx Dave that must be the explanation of it.
After the upgrade to 3.6, I had to reconfigure the frame type and I must have done it wrong.

Thank you for the analysis

(Cornel Fudulu) #5

I had a similar mishap: flat octa with Frame_class 4. And a handful of broken props.

It’s Mission Planner icons tht are misleading. You have the same flat-8 icon for both, and an X8 icon when selecting +/x orientation in flats.

1 Like
(Dave) #6

It’s easy to say but running a Motor Test is a wise move. But honestly, if I was just updating firmware on a craft that was flying I probably would have skipped this also.

(Ian Turner) #7

Check the motor order with “Motor Test” A,B,C,D order should be Front-R, Rear-R, Rear-L, Front-L. Don’t forget to increase the throttle setting to be sure it is above your min throttle setting. If this is not correct it would explain the flip and will require the servo-motor setting to be mapped accordingly so that the A,B,C,D test sequence is correct. I had this problem with a Kakute F7 board when the latest release used the default motor order but the old docs were different.

(Hugues) #8

Yes mission planner has to correct this frame selection screen as it is indeed totally misleading (and not clear at all)
Mission planner used to have a much clearer frame selection screen in older versions.