Flight modes problem

Hi all,

I have a problem trying to change flight modes on mission planner.
They always keep on “1500 mode 4” as you can see at the picture

At same time it seems that there is a “second flight mode” on failsafe screen that matches with servo output.

I don’t understand anything of this. Maybe anyone could help me?
Runnning on a two motors boat.

Thanks so much.



Normally users change the vehicle’s flight mode using a switch on the transmitter. By default that is channel 8 from the transmitter. The Flight Mode screen shown above shows that AP is configured to always set the vehicle to “Manual” mode no matter what position the Transmitter’s Channel 8 switch is put in.

The configuration is described on the wiki here.

Hi Randy,

Thanks for your answer.
I didn’t really explain very well… but I finally solved changing the transmitter channel to 8. Now I can change flight modes using switch.
I don’t know why the channel 5 doesn’t work for me.

Best Regards,

1 Like


It should be possible to use channel 5 instead of channel 8 by setting the MODE_CH parameter to 5. I normally also use channel 5…

Dear All i have same problem with X9d Plus Taranis.
Can anyone give me info, howtow or doc to the right setting of the mixers, ch etc to make sure to perform a auto mission to my marine drone. Thanks in advance

A lot of information here.

Many thanks David for your help. In the next day i try the setting and hope resolved the problem

Attached tje picture to last work in manual mode control