Flight mode setup problem

Not sure if this is the right place to pose this question – if not, please let me know…

Updated the firmware on my Pixhawk to 3.3 and also updated to latest version of Mission Planner. After installing new firmware, worked through initial setup wizard and things seemed to be going fine…when I get to the flight mode setups, none of the drop down menu have any choices for selecting flight modes to assign to the various flight mode #'s (1 through 6)??

Have attempted to reinstall the firmware and have restarted mission planner and the setup wizard multiple times with no change?

Since I’m fairly new to this, my guess it is something simple that I’m missing – if anyone can point out a solution for me it would be much appreciated!

You might try this solution:
Save your existing full parameter file.
Set the full parameters to default.
Then reload your existing full parameter file that you saved previously.

Thanks for the suggestion TCIII…unfortunately, no luck

Seems I just can’t get Mission Planner to give me any options for setting flight modes, although when I look at the full parameter list, I can see there are flight values [11,5,10,12,2,0]

The main LED on the Pixhawk is blinking double yellow [“Failing pre-arm checks (system refuses to arm)”].

Try this:

Open Mission Planner.

Go to ‘Help’ tab.

Choose ‘Check for updates’

Download latest update (yes, again).

Report back on your findings.


I have this same issue. i followed the setup guidelines on this website to the letter. the firmware loaded fine and is the latest stable APM copter will load, drone makes the musical tones when being plugged in. The only things listed in the Initial setup left column are “install firmware” and "3DR Radio. i really want this to work with all the money i have invested in this project, but its tough hitting a roadblock like this so early in the setup process.

GeorgeK each time I try to do that (over the last few days), I get an error message “Unable to connect to remote server”

I was able to temporarily work around the issue by using APM Planner instead of Mission Planner - was able to get my flight modes setup that way…

Also, regarding my earlier post regarding the double blinking yellow…I must have a short or something loose somewhere, because now when I get the double blinking yellow, if I move the copter around a bit (i.e. shake it) it will eventually correct and no longer blink yellow…I have been able to get in a few flights this way…sometimes connecting to GPS, sometimes not…

Latest update…solved the “unable to connect to remote server” error by turning off my firewall protection. Ran the updates again as suggested by GeorgeK and all seems to be working now – at least in Mission Planner. Also got the Taranis radio configured to use two switches (one three position, one two position) in combination to get 6 flight mode options…Now, hopefully the weather will cooperate so I can get out for a couple of test flights to see where I’m at!

I upgraded my MP from 1.3.24 to 1.3.32. After erasing the EPROM in my APM and reloading 3.2.1 and calibrating accelerometer and compass and transmitter etc, I went to set the flight modes and there were no choices available. I went to the parameter lists to set the flight modes there, and they were empty. I turned off my computer and everything and muttered some horrible things and went to lunch.
When I returned, I restarted my computer and MP, and looked for updates for MP. Afterwards the various missing screens and data magically appeared, and now I can set flight modes and look at parameters and do all sorts of wondrous things. I wonder what caused the difficulty…

Ok, so this looks like an issue with the mission planner not being able to get the parameter descriptions from the centralised server. When the latest version of the MP was downloaded I think it comes with a set of parameter descriptions pre-loaded so that’s likely why it worked after updating it.

It’s not really an issue with the flight code so I’m going to close the issue here if that’s ok. At the risk of passing the buck, this isn’t something that I can directly fix because it’s not a flight code issue but I’ll report to MichaelO (who does the vast majority of the MP development) these ongoing issues with MP parameter descriptions.
Here’s the MP issues list as well in case that’s helpful: github.com/diydrones/MissionPlanner/issues

Cool! Thanks,

@bergquistd :

just read your flight mode contribution and I’m wondering :question: if you could give me a tip to solve this too, I’m stuck for weeks with a Taranis 9e. How do you solve the 6 flight mode thing? :unamused:
Greetings! :slight_smile:

:question: :confused: [quote=“Bernardo”]@bergquistd :

just read your flight mode contribution and I’m wondering :question: if you could give me a tip to solve this too, I’m stuck for weeks with a Taranis 9e. How do you solve the 6 flight mode thing? :unamused:
Greetings! :slight_smile: