Flight Mode Setup - No Options Available

This is what the manual says -

You can set up the flight modes available on the transmitter by doing the following:

1 - Turn on your RC transmitter
Connect the Pixhawk (or other flight controller) to the Mission Planner
Go to the Initial Setup | Mandatory Hardware | Flight Modes screen

2 - Use the drop-down on each line to select the flight mode for that switch position.

3 - When finished press the Save Modes button.

But what do you do when the drop-down menu is blank, and has no option available?

What flight controller and firmware are you using.

I have just experienced this in Mission Planner but it was when I connected to a PixFalcon loaded with the PX4 flight stack, which Mission Planner does not read

Pixhawk with latest FW and MP Beta

Did you try hitting “Control F” in Mission Planner and select “Param Gen”? I had something similar once and that fixed MP for me.

1 Like


That did it, thank you so much Joe. :grin:

I also want to thank you Joe, yours was the only post that solved this issue. I will throw this out, I could see the flight modes when using my Win 7 desktop, but not when using my Win 10 laptop. Not sure if that is part of the issue, but more info cant hurt.


For me,
Frame type set through parameter only , that is custom Frame Type i.e. FRAME_TYPE = 18 (BetaFlightXReversed), and this caused problem.
So to fix it, selected Frame Type from Mission Planner as Quad X and later changed to FRAME_TYPE = 18 (BetaFlightXReversed) in Parameter List

thanks for the feedback here, sounds like might need to fix this