Flight mode change failed


Traditional Heli 600mm blades 1500 rpm head speed.
I see not too much vibrations
flight modes changes from rc transmitter are showing on mission planner
Pre-arm check are ok
Cheked vibrations in flight and they seem low.
EKF status seem ok too
I get gps glitches
and I cannot change flight mode : Flight mode change failed
ALT HOLD does not want to engage as well as LOITER

What I should be looking for ?

Tried to upload file but I am not able to see attached file.

Arducopter will refuse to switch to Loiter if you do not have a good GPS lock. There may be other reasons, such as EKF variance.

The dataflash flight log will contain an error which will tell you exactly why it did not change flight modes. The error will be something like ERR: FLIGHT_MODE-16. If you upload the .bin log, we can examine it for you.

Found my problem,

I was powering the Pixhawk only trough the servo rail.
I run 8S and I did not used the power supply that come with the autopilot
I put voltage in the power connector and it everything seem fine.

Need to trim Collective because it jump down when I leave ALT_HOLD.

Thanks for your help

Reviving this topic as I’m in the same situation, flight mode change failed. I recently changed my telemetry system in my helicopter over to a 4G LTE system and I’m using that system to control my Pixhawk so I’ve lost the ability to use my Taranis as anything other than a USB joystick without the switches. So I have recently tried to start a fully automated flight from the ground as well as trying to take off in loiter mode from the ground and neither work, here is a link to the thread I started earlier about it. Loiter and auto takeoff