Servers by jDrones

Flight mode change failed when using Intel Realsense Tracking Camera as GPS

I am trying to use the Intel Realsense t265 Tracking camera as the GPS for my rover. To set up the parameters and code, I used the following link: https://ardupilot.org/rover/docs/common-vio-tracking-camera.html

However, when I run the code t265_to_mavlink.py, my rover does not appear in the simulator, and when I try to switch to guided mode, it says “flight mode change failed.”

The other errors that it gives are “Bad compass health,” and an EKF failsafe. We tried changing to the camera’s compass and turning off the compass but still got a failsafe (the failsafe was not specific).

In the simulator we can see the values changing for " VISION_POSITION_ESTIMATE" as they should.

Has anybody gotten the realsense camera to work as the gps in guided mode? or have any suggestions?

Let me know if you need more information.

Thanks,
Julia

Can you try ArduRover-4.1.0-dev version?

Yes, I just tried Rover 4.1 and I get the same error. I am no longer having issues with bad compass health or EKF, but I still cannot change to guided mode. It says flight mode change failed.

Servers by jDrones