Servers by jDrones

Flight mode change failed on skit steer rover

pixhawk
(Diego Rivas Lazala) #1

Hello everyone!

I’m having trouble having a mission ran on my skit steer rover because on the flight data screen I keep getting a message saying “flight mode change failed” and EKF flashing in red. I try setting the flight mode to auto on my 3 position switch on my Spektrum DX9 transmitter and get the message mentioned previously along with the rover goes in a circle if I have a waypoint defined as part of the mission. The transmitter can control the rover when it’s on the manual flight mode. Additionally, the flight data screen also prints out “error compass variance” in red. How do I go about fixing all of these red messages and getting the rover to work on auto flight mode?

The specs of my rover:
PPM Encoder from Spektrum AR600 6 Channel receiver to RC on the pixhawk; the PPM encoder’s connections into the receiver go as such: (CH6=>AUX1/CH7=>GEAR/CH4=>RUDD/CH3=>ELEV/CH2=>THRO/CH1=>AILE)
Sabertooth 2x12 ESC set to mixed mode on the dipset switches (1=>ON/2=>3=>OFF/4=>ON/5=>ON/6=>ON)
I’m running ArduRover 3.4.2
Here are my parameters and telemetry logs:
https://bit.ly/2I9KgGF & https://bit.ly/2HJXQSe

(Dave) #2

Tlogs are of little value for troubleshooting, post a dataflash log.

the parameter file shows you have not calibrated the compass. All the offsets are at zero.

(Diego Rivas Lazala) #3

I apologize for the late response but I had my rover at school and didn’t have immediate access to the vehicle. Here is a folder with 4 dataflash logs that are .bin: https://bit.ly/30Xn47f

(Dave) #4

You still haven’t calibrated the compass. If there is an EKF error, which can happen because of this, it may refuse to switch to an assisted flight mode.

Also, you do not have this configured for Skid Steer as the post title implies.

(Diego Rivas Lazala) #5

How would I configure the rover to be skid steer? Would have to be in the parameters and if so what would the parameter be called?