Servers by jDrones

Flight Mode Change Fail

Hi, I try this 4.1 beta unfortunately now it can not change Flight Mode to Auto. From the EKF status windows, all marked as OFF but velocity_horiz, pos_horiz_abs and pos_vert_abs label as red. I’m sure this cause the firmware to reject the auto command, but I do not have this issue with 4.0 stable. What can I do to resolve this. Thank you.

I reinstall the 4.0 stable just to confirm and yes, no problem to switch to Auto once those flag are clear

@keeyen,

Can you include an onboard log? The most likely cause is the GPS quality is not good enough for the EKF to get a good position estimate so if the vehicle is moved to a more open area it will probably be fine. It may also be that it just needs a little more time.

Hi Rmackay

Here’s the Bin file. I’ll install the beta firmware again and try again. Anyway once I switch to the 4.0 stable, it’s OK.

https://drive.google.com/file/d/15zbL0vYqJpYc5KUV76ta7QE6tlG0orm6/view?usp=sharing

Thanks

Keeyen

Hi @keeyen,

The arming checks have been turned off which is normally not a good idea. Enabling them may cause the issue to be displayed on the HUD.

This log looks like it’s from Rover-4.0… any chance you could provide the 4.1 log? It might be necessary to set LOG_DISARMED = 1 in order to allow creating a log before the vehicle is armed. This can lead to a lot of logs being produced though so probably best to restore the param to 0 afterwards.

Txs for giving 4.1 a try!

Morning!

Having the same issue here with a large rover. 4.0 stable but 4.1 will not go into Auto saying GPS signal not good. However, MP is showing both GPS and GPS1 with RTK fixed. Will try to get a log uploaded. Sincerely appreciate your time.

-Steve-

1 Like

@Swebre,

Great, looking forward to the log.

The EKF will not give a good position estimate if the GPS, IMU, barometer and compass data don’t fuse well together. It really can be any of the sensors that can cause the problem but most often it is a poor GPS signal.

In this case though with both GPSs giving RTK fixed it may be more likely that it is the IMU or compass. So for example, if the accelerometers haven’t been calibrated that leads to an apparent acceleration that doesn’t match with the GPS that might be reporting the vehicle isn’t moving. Similarly the gyro biases could be inaccurate because the vehicle was moved soon after power-up or because the temperature has changed a lot. This means the EKF becomes confused because the gyros say it’s rotating but this doesn’t match with the compass which says the yaw/heading is stable.

Let’s see what the logs say but it’s possible we need to improve the reporting to give a better idea to the user what the issue is.

Hi @rmackay9,

I’m not sure is related, but I have one question, I’m testing hover without GPS - the GPS is disabled, and I’m trying to use with a wheel encoder run some missions or guided, and I can’t set the model for auto or guided, there sometimes AHRS error messages and sometimes not, and even without AHRS problems I cannot set the mode for guided or auto.

@juvinski,

I guess you’ve set the EKF origin of course by right-mouse-button clicking on the map using Mission Planner and then “Set Home Here” >> “Set EKF Origin”?

I’ll need to see a log I think. It might be best to set LOG_DISARMED = 1 so that we can get log information even before the vehicle is armed.

Servers by jDrones