Flashing copter 3.5.7

I’m trying to flash copter quad 3.5.7 to a black cube. I get to the point where I unplug, click ok, then the instant I plug in the USB cable I get the error in the attached screenshot.

I’m using the latest beta of MP

I can flash 3.6 without any problems.

Where can I download the binary for 3.5.7 so I can try loading it locally?

Thank you.

Delete, I see you already tried pick previous firmware and got that error.

please use MP beta. I fixed this bug last night

Hmm, as I mentioned I thought I was on the latest beta. Just to be sure I clicked “check for beta updates” again and I still can’t get this to work. Here’s a line from the console window - am I on the right version?

INFO MissionPlanner.Utilities.Update - New file Check: local 1.3.6878.40374 vs Remote 1.3.6878.40374

beta atm is 1.3.6883.23450

I did the beta update again this morning and it went to 1.3.6884.18567, but I still could not flash 3.5.7.

I reinstalled the release version of Mission Planner, did the beta update, and am on 1.3.6884.18567 again.

Where can I just grab the latest beta installer, rather than installing the released version and updating to beta? The binary at http://firmware.ardupilot.org/Tools/MissionPlanner/beta/ says March 18th…

Thank you.

6884 should be fine.

did you get a question about uploading chibios? answer No. 3.5.7 never had a chibios build

No I didn’t get the ChiBIOS dialog - I’ve only seen that with 3.6.

6884 isn’t working for me, even after a clean reinstall. Is there anything I can do to track down what’s wrong? Or information I can send you?

In the interim, could you tell me where I could download the binary for 3.5.7 copter quad so I can load it locally?

idealy the records from the MP log file

c:\programdata\mission planner\missionplanner.log

Here it is. I started a new log file. I connected to the cube on com5 to verify MP could do that, then disconnected MP and tried to flash quad 3.5.7. As soon as I plug in the cube after the power cycle I get the invalid URI error.

I can flash current firmware just fine, it’s only when I try 3.5.7 that I get this error.

Thanks for your help.

MissionPlanner.log (219.2 KB)

I did some more testing on this problem. To eliminate the possibility of a problem with my laptop or Mission Planner installation, I took a different computer, empty disk partition, installed Win 10 Pro from scratch, installed Mission Planner, updated to Beta (1.3.6885.41507), and tried again to flash ArduCopter 3.5.7 Quad to the Cube. I’m still getting the “Invalid URI error” and flashing fails. Installing ArduCopter 3.6.0 works fine.

Since I have the same problem, I join in here.

I’ve got multiple Pixhawk 2.1 most of them with older firmware, one with 3.6.0 and I get the exact same message as shown in the first post for all of them when I want to go to 3.5.7.
I can not use 3.6.0 since I’ve got some lag of around 1 s in the servo signals over mavlink which makes it hard to control my gimbals precise.
I’ve tried the actual stable Version of Mission Planer and the latest Beta build 1.3.6885.41507 as well.

Best regards

One more test - I am able to flash a Pixracer from copter quad 3.6.0 to 3.5.7.

Works for me now with latest beta update 1.3.6889.16383. Thank you.

took abit of hunting down. but the log did help. thanks.

Works for me now too. Thank you