Servers by jDrones

Flashing Arducopter over Inav Kakute F7 1.5

I have a new Kakute F7 1.5 with INAV on it. I was trying to flash AC4.03 over it.

For the life of me I can not get it to take

I have downloaded the firmware with Bootloader

https://firmware.ardupilot.org/Copter/stable-4.0.3/KakuteF7/

I hold down the bootloader button and try to flash within MP. The question gets asked “is this a linux board”

For the life of me I can not get AC on this board.

Thoughts?

Using iNav Configurator. Hold the Boot button down and connect to USB (DFU shown in connection box). Select Load Firmware Local and then select the with_bl.hex file you downloaded. Flashing will commence and complete. You are done.

I know this works because I flashed iNav to a Kakute F7 AIO on the bench and then flashed it back to AC. It’s not a V1.5 but I don’t think that will make a difference. Or you can use Betafalight Configurator if you like but because I was already in iNav…

If it doesn’t work and you need tools with more horespower try the application in this link. Don’t worry about it being a Matek page it’s an ST Micro tool.
http://www.mateksys.com/?p=6905

Thanks @dkemxr I will try those tools. I have tried the DFU-utils on linux. Inav configurator on linux and windows. And nothing :rage:

I was able to originally flash Inav over betaflight

On a couple of my 7" quads I am running Inav, and not caring for it all that much. So I want to try AC :slight_smile:

I flew a little 130 3" on iNav briefly but I wasn’t that familiar with the system and flashed to AC. Which worked OK, but it has BF on it now. Equal opportunity abuser :grinning:

1 Like

I actually just added a TFmini + to this quad

Going to try it on INAV first, but then flash over to AC.

Smallest little quad with lidar lol

@dkemxr

I think I found out why I can’t flash my flight controller. I found this little tidbit of info on the Maytek site:

If GPS or other devices are connected to UART1 or UART3 of F4/F7 chip and these devices are powered ON while connecting USB. FC can’t enter DFU mode. It is related to DFU protocol used in the STM32 bootloader, not hardware and PC driver issue.

And guess where my GPS and VTX are connected… :grimacing:

Wonder if someone could help my out. I need to enable the ist8310 mag driver in 4.0.4-dev for the kakute f7. I am not a programmer and not sure where to start

I have a GPS module connected to UART3 on the Kakue F7 I did the bench trial with. But anyway, did it work after you disconnected the UART devices?

As soon as I disconnected the GPS I was able to flash it. What I did was I moved the gps power over to one of the “powered by battery and not usb” power pads. Once I did that good to go.

I did have a problem because the compass drivers were not installed. However @andyp1per helped me out with that.

The only thing I don’t have working yes is esc telemetry. I have the tekko32 F3 meta 4:1. It’s supposed to be on uart7 which maps to serial 5. But no luck yet.

I did find that the AC docs on the motor order are wrong however. Motor mapping is 1,2,3,4 corresponding to servo 1,2,3,4

OK, cool! Yea, the motor order on some of these boards is not always clear. I just wire-em up the most convenient way based on board orientation and then re-map them in firmware after running Motor Test.

Exactly what I did. Do you have telemetry working? I think you have one of these boards right?

I do but it was in a Plane without a telemetry capable ESC and it’s on the bench now w/o an ESC to test it with.

Ok thanks, I might enable auto telemetry just try and see if I can get something

Actually I got the Telemetry working… Looks like it was not being sent to MP event though I have mavlink2 enabled. Either way it is getting logged so I am good.

So this project is going on waaaayyy longer than I expected… But I have learned a lot

Not too shabby for a 280 quad

Looks good! ESC telemetry reference or FFT?

ESC telemetry based dynamic notch. Now just trying to figure out why the notch (CTUN.N) isn’t getting logged

Servers by jDrones