Servers by jDrones

Flaps. Arduplane

Hi.
My kit.
FrSky Taranis Q X7S 2.4GHz ACCST 16-Channel Transmitter Carbon Fibre
FrSKY XSR-M 16-Channel Receiver
Matek F765-Wing flight controller.
This will go into a fixed wing model.
I have everything setup with the exception of the Flaps.
In Ardupilot Radio calibration the channel shows and responds as expected.
Flaps 0
In Servo Output there is no response on the Flaps. All other channels are working.
Flaps

The SERVOn_FUNCTION parameters Flap=2
Flaps 1
Sorta stuck at the moment. Again looking for advice on how to do this.

FLAP_IN_CHANNEL: Flap input channel
An RC input channel to use for flaps control. If this is set to a RC channel number then that channel will be used for manual flaps control. When enabled, the percentage of flaps is taken as the percentage travel from the TRIM value of the channel to the MIN value of the channel. A value above the TRIM values will give inverse flaps (spoilers). This option needs to be enabled in conjunction with a FUNCTION setting on an output channel to one of the flap functions. I have found this information But I do not understand what they are saying.


Have tried putting different settings on here.

Regards Antony

You will see the effects of these parameters only when the vehicle is in motion. Essentially, these parameters set two critical flight speeds below which the flaps engage partially up to the specified percentages of the full flap motion. One way to see the effects of these is to use SITL simulations with you preferred flight simulator.

The FLAP_x_PERCENT parameters can be set and used manually without the speed parameters. SITL is not needed for testing manual control of the flaps. You could also use a leaf blower on a pitot tube if you wanted to test the FLAP_x_SPEED parameters.

0% = SERVOx_TRIM
100% = SERVOx_MAX

Servers by jDrones