Servers by jDrones

Fixed Wing Crash after successful Auto Takeoff

arduplane
(Chad Frazer) #1

Very unusual crash. I don’t want to taint anyone’s analysis so here is the link to both the previous flight logs and the actual crash logs. I’m not ready to rule out mechanical failure but since the aircraft was recovered I can say that mechanical failure is not likely based on inspection.

Please tell me what you guys/gals think.

https://drive.google.com/drive/folders/0BxaPtEd6MGy7eVlIam5NSDZCOG8?usp=sharing

1 Like
Crashed in take off with firmware "Arduplane 3.7.1",Why?
(Hunt0r) #2

I’m looking at it: It appears that takeoff happens around 425 sec, and flew to 45m altitude, achieving that around 439 sec. At that point, the pilot changed the mode to STABILIZE (for 2.6 sec) and then to RTL. I think it was in RTL when it crashed.

A suspicious thing I see is that from 335 sec to 425 sec, which is before takeoff, the roll from ATT.Roll is going crazy… reporting values as much as 20 deg! The pitch is bad too, errors as high as 15 deg. What was happening on the ground?

Assuming nothing particularly unusual was actually happening, I’d suggest this might be the source of your problems… a plane that’s sitting still and thinking it’s rocking-and-rolling plus-or-minus 10[deg] is a bad plane to fly.

@Chad_Frazer What do you think? Does this sound reasonable?

Did anyone else take a look?

(MagicRuB) #3

Looks like a mechanical failure.

CTUN on left, Baro on right.


This plot shows you never had roll control. The autopilot is commanding roll-right but it continued to roll left. As you switched over to Stabilize, it just rolled more. By the time you switched to RTL you were already in a death spiral from a stall.

Naturally, your Roll Integrator (PIDR.I) is going nuts. This is consistent with a mechanical failure. This might be a side effect of the mechanical, would have to see the dataflash of a “good” flight, but your pitch integrator (PIDP.I) is also going up which usually means a your Center of Gravity (CG) is too far back. Hard to tell on this particular log, but perhaps something broke loose inside?

(Jack) #4

Hello, trying to sort out the COG of Zeta FX79, according to ardupilot site “If your plane showed a value of PIDP.I consistently above zero then your plane was needing to put in up elevator to stay level. Your plane is probably a bit nose heavy, or your elevator trim is incorrect.”. You say “pitch integrator (PIDP.I) is also going up which usually means a your Center of Gravity (CG) is too far back.” are you sure about this ?
Thanks !

(Mike Boland) #5

Have you flown the plane in manual?
If so, did you do a CG test in flight?
This is the only true way of testing for a correct CG.