First (NON) Flight - No Joy

Received my IRIS+ this morning. Charged battery (4 hours seems ridiculous), installed tall legs and props and went out for a quick check. When I connected battery got several beeps and flashes and had green flashing status light almost before I could close the battery door so I pressed the safety button until solid red and stepped back expecting to be flying soon. [color=#FF0040]NO JOY! :frowning: [/color] When I moved the left stick back-right, after a few seconds there was a high=low tone, but the motors did not activate, NADA. Telemetry looked good, 12 sats, locked, 12.5 V on IRIS, 12.2V on radio, etc., but no motor action. I shut down reread the manual, checked troubleshooting info, connected Mission Planner and checked radio calibration, compass may be a little off, but not much. Haven’t calibrated anything else yet. But didn’t see anything strange either. What should I do next? I don’t want to mess anything up. Should I remove covers and check connections, etc.?

Doesn’t sound like there is anything wrong with the copter. The High-Low is telling you that it can not engage the motors right now. This can be caused by not pushing the Red button or choosing a flight mode that requires something that is not ready.

Check the radio switches and choose a mode that is ready.


Check the message log in Mission Planner and see why the copter is not Arming. It will state why.

Make sure to check this too. Mine was way off in roll when I received my Iris.


First, thanks all for your responses, this has been a real learning experience, but I think I have it sorted out now. Part of my problem yesterday was operator error, but I still have a serious problem. Weather Sunday was a mess, but in late afternoon I got enough of a break to setup IRIS on the driveway, sans props, and the laptop and Tx on the carport. I can’t setup inside because I can’t get GPS due to a steel roof. My operator error on Saturday had been that I misinterpreted a flashing yellow status light for flashing green.
The green led in my IRIS is so much brighter than the red that when they flash together the resultant yellow has a decidedly green hue, particularly when viewed from slightly left of center, so when I thought I was ready to arm I, in fact, had a problem. I did not take the laptop out with me Saturday or I might(?) have seen the problem then. The first time I fired up Sunday I got a VERY definite GREEN, and the motors armed and appeared to operate flawlessly. I shut down and started up again without a problem, but then I shut down and disconnected the battery. I then reconnected the battery, and this time I got the greenish yellow which I had been seeing Saturday. I then repeated the procedure multiple times with the same result every time. The error message is “PreArm gyro cal failed” followed by “Bad gyro health”. In addition to the IRIS problem, I have been having Internet connection problems so this is the first time I have been able to get on since the test. I thought I would send out this status message before doing anything else. Further suggestions would be GREATLY appreciated. Thanks again for your help!

After posting the last message I went to the wiki and read up on Pre-Arm Safety Checks. After reading about the “gyro cal failed” I think I might be causing the problem since it says jiggling the copter during the checks may cause this message. I have been closing the battery door immediately after plugging in the battery, and getting that connector stuffed inside is a bit of a hassle. When daylight returns, I will try waiting to close the door until after the Pre-Arm checks are complete.

PS: I am completely overwhelmed by the amount of reading I apparently need to do! :unamused:

Problem solved! And my face is plastered with egg :blush: . This whole miserable episode was apparently attributable to pilot error. Plug in the battery and don’t touch IRIS again for 10-15 seconds and everything appears to be good (multiple times). Unfortunately, we have a north wind gusting into the mid 20 mph range this morning, not what I want for a first flight. :wink:

I purchased by IRIS for the journey. Learn something every day and loving it.


I had the same problem with mine I was so used to the other quads that I had where it made no difference if you moved it or not that I did not think about it with this, I had mine hooked up to the computer and it said Bad GPS Health and only after calling 3DR support did I get the answer of not touching the Iris+ until it has GPS lock. The tech support at 3DR is really spot on they have helped me a few times since I have purchased my new Quad and I cannot say enough good about them. I just love this thing and really wish I had not wasted my money on that Blade and DJI junk and just went with this one. All part of the learning curve I guess.

I agree 100% The more I read, the more capabilities I find this machine to have. Seems to be far far more refined than anything else I’ve had to date. :smiley: