First auto mode and crash

hi, today i tried my first fly in auto mode but the quadcopter crashed at first waypoint and i don’t know why,
i have tried it before in loiter and alt Hold mode and it works. I saw the log file to point out the problem but i didn’t figure out.
I thought the problem was the interference in the field because in the log there are a lot of pitchin yawin and rollin spikes but i read that in auto mode the copter doesn’t “read” the input from the radio, so i don’t know why this happened
have you got any suggestions please?
Thanks to all and sorry for my bad english :smiley:

i saw the chanal 5 (for mode select) change in the log but my fly was all in automode except during the arming procedure, also in the log mode i see different mode during the flight, i don’t think it’s normal correct? so it was a interference the cause of the crash. do you agree?

Logging needs to be turned up. 830 isn’t going to cut it. … og_bitmask

Set it to NearlyAll for testing then set it back down when done testing.

From the logs it look like it was doing what it was suppose to but the mode channel kept changing and messing with the mission. Need to see what the radio was doing.


Sorry i don’t understand what you are saying about the 830 “isn’t going to cut it”.
In my log it is all in 830 isn’t that enough?
And for the radio it was set as standard and i didn’t touch anything during the flight.
if it helps i have also the telemetry log (the flight start at about 73%)

The logging need to be changed from 830 - Default to 45054 - NearlyAll.

That way we can see the RCIN, RCOUT and a few other things in the logs.

Set it back to 830 when you are done testing as it slows down the flight controller.

To set this parameter go into Mission Planner and connect to your copter.

Next click on the Config/Tunning Icon.

Click on Standard Params and scroll down to Log bitmask(LOG_BITMASK) and click on the down arrow.

Pick NearlyAll from the drop down.

Click on Write Params at the top of the screen.