First 4.0 Rover build

Hi everyone, building a rover for the first time using Cube and Sabertooth duel controller and have come against an issue With the 4.0 beta I don’t fully understand as not done a rover for a long time.

the setup is 4 motors wired left and right in pairs, Iv set the input to separate input now on the controller and set Rover to LH and RH side Motors and calibrated the RC input on the controller correctly .

testing in Manual mode I have noticed something odd in thst that’s the servo output on throttle and steering is vastly different to the calibrated RC values and it’s causing the motors to run at centre stick.

Settings is
Servo 1 and 3 In skid is set as 1100 Min, 1900 Max and 1500 Trim , RC is calibrated and all looks correct on RC setup with all movements as would be expected.

At mid stick I can see the RC at 1500 or so Pwm but the output servo pwm is around 1700 or 1300 depending on if I reverse the channel and the motors are running.

To get it to centre to 1500 I have to trim the servo output to 1200 or 1800 in the servo screen to get the output to be correct at 1500 and it to not run.

Any suggestions as i can’t seem to work out why it’s got such a difference in output vs input.

Hi @BFM1,

In general it’s best to post a dataflash log file. This gives us a lot more detail of the setup and configuration. Without this it requires a lot of guesswork.

Have you run the motor test?

Two common issues we see with new setups are:

  • The PILOT_STEER_TYPE parameter has been set to a non-zero value. Most users should leave this parameter at 0.
  • RC3_TRIM is set to a very low value. Make sure it’s about 1500 although it sounds like you’ve already done this.

Post a dataflash log and that will help a lot I think. txs

1 Like

Hi Randy thanks for the fast reply, sorry was late here last night and has been on it for a while.

Ok please see below prams file and screen shots.

In Manual with trim at 1500 it just rolls the motors on its own, If I trim to the values shown it does not

In Acro it just tries to take off no mater what I do, literally this is at the bench testing stage right now so not done the rates yet.

For this pram file the trims are back at 1500 and its just running the motors by its self at centre stick

Config Non Trimmed.param (15.9 KB)

This is how it is with centre stick and its runnig motors as you can see servo is at 1672

This is trimmed and the motors do not run and behaves in Manual but takes off in Acro

This is RC Calibration


RC3_TRIM = 1863. This should probably be reduced to 1500.

I suspect something went wrong during the RC calibration, perhaps the sticks weren’t at their center position during the stage of the RC calibration that it requests this.

Hope this helps

Dang that’s odd. Thanks randy will check it out again in the morning And report back.

I’m sure I calibrated twice as well but tbh can’t confirm 100%. I need to look up what that’s about now.

1 Like

Thanks Randy that was it. Really odd. Something must have been off when I calibrated but had done it multiple times.

Now on to proper setup and then all the calibrations.

1 Like

hello i want to ask you something please if you have time. I have started to build a rover too with a pixhack 4 and i did everything according with all the instructions out there, I even try this conversation that you guys have here, i got the mission way points ready, all sensors are ready, radio is ready, fly modes ready,even GPS is ready, but rover is not starting in auto mode, i have 3 modes, manual, auto,simple , does not want to start on auto mode, i am using my radio buttons one on the right, for throttle and ,steering, for arming im using channel 8 and for fly mode channel, 5 i dont know if thats the right radio setup, i have taranis plus radio.this is the page where a red about auto mode []( , rover is responding on manual mode, turn on motor and steering servo when is arm. . I dont know what else i can do to make it run. Can you please help me. thank you
ps. I don`t know how to upload data log file. can you show me how.