Firmware will not download

I think I have the easiest system imaginable. I have 3-channel EasyStar running on a Futaba 6 channel radio with an Ardupilot APM 2.5 board. The Mission Planner software is installed on a Windows 7 laptop and device manager shows COM4 when I attach the APM to the laptop via the USB port. However, I cannot get the airplane firmware to download (ArduPlane V2.73). I get the message “Failed to download new firmware: System.ArgumentException: The given port name does not start with COM/com or does not resolve to a valid serial port. More unintelligible stuff…”

Can someone tell me how to get the firmware installed on this unit? All the lights flash and the baud rate is properly set.

@Mark82GPB,
Make sure that the Mavlink is disconnected (not the USB connection) before trying to download new firmware to the APM.
Regards,
TCIII

How would I disconnect the Mavlink? I take it that it is not a physical device.

Mark82GPB,
Since you say that you have the baud rate set correctly then what is the COM port number in window next to the baud rate window? Your error message is saying that there is not a valid COM/com port number available for the connection to the APM.
Regards,
TCIII

I think I figured out where the Mavlink connect/disconnect button is - top right corner of the MissionPlanner screen, yes? The computer (Device Manager) says I am using COM5. When I try to install the firmware I get the message box: “Failed to download new firmware: System.ArgumentException: The given port name does not start with COM/com or does not resolve to a valid serial port. Etc.” Maybe I missed something somewhere: is there a step by step set of instructions on how to set up an aircraft using this hardware and software? I feel as though I am just stumbling about. What lights should I expect to be lighting when I power up the board? A yellow light near the “FORWARD” sign on the case flashes at a very high rate - is this normal? At what point should my radio be able to operate the aircraft controls - can it operate them with the USB cable attached?

@Mark82GPB
Try here for instructions: plane.ardupilot.com/wiki/arduplane-setup/

Regards,
TCIII

I had the same cryptic messages about the correct COM port shown on the device manager, not being available. After rebooting the computer the COM port was free and the V2.73 software loaded OK.
Now I am at the stage where I cannot find how to install the Bixler parameters!

@Galand,
If the Bixler Ardupilot parameters are available in a standard parameter file, then what you do is go to the Advanced Parameter List. In the Advance Parameter List will be Save and Load buttons. You can use the Load button to load the Bixler parameter file. Just point the loader to the where you have the Bixler parameter file stored.
Regards,
TCIII

I have the Bixler parameter file but I cannot find where the load function is in the Mission Planner. The instructions show a green field at the bottom of the configuration screen (in my case it is called “Hardware” 3rd tab from the left) that says “APM Set UP (Plane Quad)”. My configuration screen does not show such a field.

@Galand,
What version of the MP are you using? The newer versions, 1.2.57 and .58 are different from 1.2.53 which I am using at the moment. However, there is an Advanced Parameter List in 1.2.57, but I have to have my APM hooked up to the MP to see it because it is specific to the vehicle.
Regards,
TCIII

This morning it updated to Version 1.2.59. The screens look different from the posted instructions.
I tried to attach a .doc with a Print Screen to show you, but this site does not let one attach .doc nor .txt . What use is that? :question:
Also, I cannot find which formats are accepable to this site.

@Galand,
You can use the IMG button at the top of the editing window to attach an image. A screen shot can be saved as a jpg image and inserted into your post.
Regards,
TCIII Admin

I re-downloaded Mission Planner and re-installed it. It installs properly until it gets to the firmware part. At that point it gives an error message: “Unable to connect to the remote server, at ArduPilotMega…configFirmware.cs.line247 and at … line 77.” No firmware are indicated under the various aircraft shown on the Mission Planner screen. How do I get the firmware?

I have the APM 2.5 firmware loaded now in Mission Planner 1.2.59. I connect the Ardupilot to the Windows 7 laptop via USB and click on ArduPlane V2.73. The blue LED on the board lights up and the laptop installs the firmware on the Ardupilot. At the end of that process, the long bar at the bottom of the hardware screen has changed to green and the word “done” appears. I believe I should now be able to run a setup routine to adjust my transmitter controls, but no setup button appears on the Mission Planner screen. Can you tell me how I can go about the setup procedure?

Hi Mark.
Seems like you reached the same dead end. I also could not find the green rectangle at the bottom of the “Configuration” (now called “Firmware”) screen in version 1.2.59… In the instructions it says that that is where you click to start the set-up.
Craig, please help!

Cannot figure out how that “img” function works. Have been fiddling with computers for 30 plus years and am only moderately intelligent. Posting pic’s on RCgroups is childs-play. Saw another poster also wondering what format to use to attach a picture.

Apparently the latest version of Mission Planner has dispensed with the setup button at the bottom of the hardware screen, as well as the firmware tab at the top of the screen. In their place you now have firmware indicated below the aircraft icons and the setup menu is on a tab at the top of the left side of the screen (see plane.ardupilot.com/wiki/table-of-contents/). I tried to configure my my radio transmitter according to what was on that web page, and it went through the process of trying to assign the throws to the various transmitter sticks. However, none of the stick throws registered with the on-screen display. I tried it twice with the same result. Not sure how to get the transmitter to sync with the autopilot.

I replaced the Ardupilot APM 2.5 with an identical unit in the aircraft. This time everything uploaded and worked fine. So I think the first board was defective. I will try to send it back.

Hi, I have a very similar problem. When I try to install the firmware for plane it says:
“Failed to download new firmware: System.UriFormatException: Invalid URI: The URI is empty.
at System.Uri.CreateThis(String uri, Boolean dontEscape, UriKind uriKind) …”
I tried everything suggested on the ardupilot website. Makes me desperate!
Do you have any idea?

What hardware do you have?