Firmware load problems failed to connect error no response from board stuck with 4.0.0 (solved sorry funny video)

Following on from my crash on the hex I have taken out the Holybro 4 Mini and put into a new frame.
I have been trying to load the new 4.0.1, does’t work when I click ok new firmware etc.
So I downloaded copter 3.6.9 and tried to flash that.

Mission planner keeps coming up with “no respose from board” when I plug in to do load.

So i thought qgroundcontrol would work.
comes up with:
“invalid sync response 0xf4 0xe0”
open failed on port /dev/ttyACM0: Permission denied

I have tried 3 different computers.
3 different cables
Windows 10
Windows 7
Ubuntu (latest)

I have tried resetting the controller (deleted previous parameters)
Arducopter 4.0.0 still on it

I have tried different versions of mission planner and uninstalling them reinstalling
different versions of qgroundcontrol

deleted sd card content
different sd cards
everything unpluggde from controller.
plugged directly into computer and connected via a powered Hub
Unplugged everything from computer (mice etc)

Im lost. I have been through all the previous threads around this kind of issue. Tried all the suggested fixes. 4.0.0 seems to be stuck on there now forever more. I want to use the telemetry that wont work with 4.0.0. I can’t upgrade or down grade.

Good day, just try download the firmware file on your computer and flash it with the option you will find on MP… if im not mistaken it’s called custom firmware.

Sometimes is a matter of faulty USB cable. Is the board recognized as an USB device? You could also give a try to APM Planner.

Thanks all. I have no idea what I have done differently but suddenly after doing the same thing over and over it took a new firmware. Being late and after trying to flash it all day I did something stupid.
See the link to see what happens when a Hex is down 2 arms

Good day,
did you perform all the calibrations are needed?

Oh yeah I fixed the problem. Sorry the video was just to show what happens when you get the config wrong. I thought ppl might find it funny or interesting. This is my first Quad and as a result I didn’t know that mission planner top right showing hex or quad actually changed. I configured it wrong …

ok… just use gel dumps for isolate the fc, don’t attach it directly to the frame coz due the vibrations…

happy fly

Afterwards everything is funny… I guess not during the crash… But your video will be the ultimate demo video for Quad Behaviour when it thinks it is a Hex :wink: