Firmware Build Issue

Hi all. Apologies if this isn’t the appropriate category.

I’ve downloaded the PX4 Windows Toolchain (I’m running 64-bit Windows 10), and am attempting to build the firmware as per the instructions given on the website. Unfortunately, I keep getting the following series of errors:

%% Generating /c/Users/INDROR~1/Documents/GitHub/ardupilot/modules/PX4Firmware/Build/
fatal: Not a git repository: test/dspal_tester/cmake_hexagon/…/…/…/…/…/…/…/…/…/.git/modules/modules/PX4Firmware/modules/src/lib/DriverFramework/modules/dspal/modules/test/dspal_tester/cmake_hexagon
fatal: ‘git status --porcelain’ failed in submodule dspal
fatal: ‘git status --porcelain’ failed in submodule src/lib/DriverFramework
make[2]: Leaving directory /c/Users/INDROR~1/Documents/GitHub/ardupilot/modules/PX4Firmware/Build/' %% Copying /c/Users/INDROR~1/Documents/GitHub/ardupilot/modules/PX4Firmware/Images/px4fmu-v2_APM.px4 make[1]: Leaving directory/c/Users/INDROR~1/Documents/GitHub/ardupilot’
text data bss dec hex filename
940204 2844 60684 1003732 f50d4 c:/Users/INDROR~1/Documents/GitHub/ardupilot/modules/PX4Firmware/Build/
fatal: Not a git repository: c:/Users/INDROR~1/Documents/GitHub/ardupilot/modules/…/…/.git/modules/modules/PX4Firmware
fatal: Not a git repository: c:/Users/INDROR~1/Documents/GitHub/ardupilot/modules/PX4NuttX/nuttx//…/…/.git/modules/modules/PX4NuttX
Failed to get px4 hash
Failed to get nuttx hash

I’ve done a little bit of research, and I suspect that there’s an issue with the git submodules not being properly initialized, but I’m not yet familiar enough with git, make, and just building software in general to be able to fix the issue. I have already attempted deleting then re-downloading the source code, making sure to run the “git submodule update --init --recursive” command, but the same issue still arises.

Just in case it’s relevant:
-The first path that is listed as ‘not a git repository’ seems convoluted and weird; I tried to discover whether the path exists and the closest thing I could find is “C:\Users\INDROR~1\Documents\GitHub\ardupilot.git\modules\modules\PX4Firmware\modules\src\lib\DriverFramework\modules\dspal\modules\test\dspal_tester\cmake_hexagon”
-When specifying the build location, I had to use Windows 8.3 filename convention for part of the path name (i.e. “INDROR~1”), since it otherwise had spaces and was giving me errors. Not sure if doing so could introduce new errors or not.

Could be that I’m overlooking something really obvious, but I still can’t seem to figure it out so I figured I’d toss it to the forums.


Minor update: I actually went as far as to create a new user account with no spaces in the name and performed the build using the ‘make’ command within the px4_console to try to eliminate some variables. Still receiving the same error. I’m following the website’s build instructions verbatim as far as I can tell. Also I’m building for the Pixhawk, in case it wasn’t clear.