FFT analysis help

Just did some tuning on a new build. Did the filter tuning using MavExplorer. The gyro graph on the left makes me think I nailed it. Then for reasons I plotted the same log in Mission Planner (latest beta within the last 18 hours). Now I see another bump, and the scale is negative.

Here’s the log if it helps.
https://mysait-my.sharepoint.com/:u:/g/personal/allister_schreiber_sait_ca/EdGSrwRVQ4RJqekbtvrspMkBhB5bcW5T-7oeqr0equPN8A?e=QYKKDH

Is this a MP issue, a MavExplorer issue? Or do I need a static filter?

Here is the FFT Graph in Mission Planner w/o log scaling. That 93Hz is in the mud, I think you are good.

FFT

1 Like

Thanks for checking that!

I’ve checked this log on 3 different installs of MP (all latest beta), and both of the windows installs gave me a graph like the one I posted. The linux install was okay. Is log scaling something I’ve accidentally turned on or what am I overlooking?

The small “magnitude” checkbox on the FFT screen, lower left. Check it before loading the file. Personally I don’t think log scaling is that useful for the purpose we are using it for here.

1 Like

That did it. Thanks!

Interestingly that check box is not on MP on Linux, only on the windows installs.

it should be on both… might just be a gui bug

Like this issue? (also on Linux)

this issue is fixed… ill need to check the fft screen now as well