Fence not possible with GPS Blending?

Today I tried the first Time the Fence Feature. On that Octo I´m using 2 GPS with GPS blending.
GPS_Auto_Switch to 2.
When I enable the Fence he fails the Arm Check with the Argument that GPS2 is false. Although it has the same Sat Count / GPS HDOP then GPS1
Disabling GPS2 helps.
Anyone got an Idea?

You probably want to switch to failover mode vs blend. There was a discussion a while back about how a rouge gps antena\signal could introduce issues system wide. In the "use best’ mode this will not happen. The antenna with the lowest HDOP will be used

OK, thanks. I’m gonna try that next time. Maybe it has got also to do with one GPS is from Hex, other one is from Holybro. I thought the Chip inside is the same

If the chip is the same and the FW similar, it should be ok to blend them.

What exaclly is the error message? Please do not disable pre-arm checks.

I never disable prearm checks. Having a problem and just ignoring it doesn’t help :blush:
Tomorrow im gonna check again. Last Time I was in a hurry so I just disable GPS 2.
Actually in the first place I put another GPS in to solve a Compass problem with another external one. But a backup GPS would also be nice