Servers by jDrones

Feiyu Tech Mini 3D gimbal points only down

I’m very much a beginner with drones, so apologies if I neglect relevant information here.

I have a drone (Ascent Sprite) with a Pixhawk controller and a FeyuTech mini3D gimbal, and I’ve been using APM 2.0 to check what’s going on. The gimbal has previously worked OK (in manual control - auto ROI aiming is another issue), but the last few times I’ve tried to test the system, it will insistently point the camera straight down and stabilize it like that.

I’ve had this same happen previously, but after a full system reset it seemed to work fine. I didn’t adjust any pixhawk parameters that would affect the gimbal. (OK, full disclosure - I did, trying to solve the ROI issue, but returned them to original settings afterwards.)

Any pointers as to what I should be looking for when a gimbal changes behaviour changes like this?
Where do I even start? What supporting information can I provide here to improve my question?

I’ll comment to myself that tweaking the MNT_* angle parameters I managed to boot up the gimbal into the standard position once. Changing the angle control on the remote then turned the gimbal tilt to max down, and no reaction to angle control thereafter. Couldn’t repeat this retrying with the same parameters.

I’m wondering if I’ve managed to break the gimbal.

Whuppo, did you figure this out yet for the Sprite?

I didn’t. Updated the firmware of the drone and gimbal, and got very slightly improved behaviour:
the gimbal seems to lock into a tracking position (keeps stable, but doesn’t respond to control) within 0 to 30 seconds.

Based on Feiyutech input I suspect that it’s a hardware thing, maybe even a wiring glitch.

Please share your experience with Sprite so far, is the 1.0 version ready or wait for 2.0?

hello,friend,do you have more infomation about sprite,i want to commit you with facebook

Servers by jDrones