FBWA questions related to stall behavior. RTL thr_max speed

@Allister I have few questions about FBWA and RTL mode:

  1. I am flying a twin motor plane and both my motors are set as right and left for differential thrust. However, during FBWA mode I see not much effect from differential thrust. Very slow flat turn almost feels like that the plane was turning only using the rudder. Is differential thrust is disabled in FBWA mode?

  2. How would the plane react during stall in FBWA mode? I was trying slope soaring technique to keep the plane floating in the air without any power, but all a sudden plane tip stalled and got out of control spinning towards the ground. I was able to save the plane by throttling up. Something tells me I should never do this again.

  3. Can I change the throttle percentage for RTL and Auto takeoff? The document snapshot below is a bit unclear to me. Should I change Thr_Max to 50% and it will automatically will change the RTL speed?



For more differential thrust try increasing RUDD_DT_GAIN. You should be able to see a split in the outputs assigned to Throttle Left and Throttle Right. And yes, this does work in FBWA.

I’ve read from the dev’s that stall recovery in FBWA is very difficult. FBWA is great for keeping you out of a stall, but if it happens it’s going to struggle to recover, especially with the throttle off. Problem is, when the plane stalls FBWA will do almost everything wrong for stall recovery (Full up elevator rather than level or slightly nose down and, likely also full aileron deflection rather than wings level regardless of heading). By pushing the throttle up you gave it the push it needed to re-set. If you’re going to be on the edge having a quick switch to manual mode might be a good idea for those fast recoveries.

TKOFF_THR_MAX will set the throttle limit for any auto take off (mission command or take-off mode). I’m not sure why you want 50% THR_MAX, that seems really low and could seriously limit you even in simple climbs. What are you trying to change in RTL?

@Allister thanks for a quick reply.

I’ll increase DT from 10% to 20% and see if this makes a difference.

Exactly my feeling and observation…lol

My Reptile V2 aircraft is overpowered (using two 1900kv motors with 6" prop), I flew this plane at 1/4 throttle and it cruises beautifully, except when commanded to RTL or Auto_tkoff. I am afraid it may cause structural failure. So I want to reduce the speed to ~50-65% to reduce g-force during circle sequence. Are you saying to change both Tkoff_thr_max and Thr_max parameters in order to reduce RTL speed?

If TKOFF_THR_MAX is set to zero then it will default to THR_MAX. So for what you’re trying to do you probably don’t need to set both. By RTL speed, do you mean the climb to your RTL height? The RTL cruise should be your TRIM_THROTTLE setting. I’m always careful when I turn stuff like this down, so I’d start with THR_MAX 75% and work down. You may find you want different numbers for take off than cruise so you might go back to adjusting THR_MAX and TKOFF_THR_MAX.

You might also want to increase RTL_RADIUS (or WP_LOITER_RADIUS) if the plane is cranking around the turn too hard.

What I mean by RTL speed is FC taking over control, climbing or descending, cruising to home position, and going into circle mode. All these sequences I want to reduce the speed.

Defiantly I should increase the radius, before it turns into a particle accelerator at CERN. Thanks for reminding me of that parameter.

Have a look at TRIM_THROTTLE. If this thing is such a rocket ship, but you haven’t adjusted that then it’s probably up at 50% throttle on the way home, compared to your normal ¼ throttle you had cruising around. Look back in your logs and see what you had the throttle set at when you were cruising and set it to that (give or take a bit).

Without making any changes at the moment these are the settings:




GPS Speed profile:

Leave TKOFF_THR_MAX at 0 for now, and turn down the other two and test it out. You can probably set THR_MAX to 75% and TRIM_THROTTLE to 35% without too much worry. If you have THR_PASS_STAB set to 1, you can always go back to FBWA and give it the beans if you need to.

ok. I’ll make the change and try out next weekend, weather permitting.

1 Like

what you should be looking at is STAB_PITCH_DOWN, that adds some down nose trim when the throttle is at idle in FBWA to keep your airspeed up and prevent it from stalling when gliding.

After making the changes as listed above, my right side motor did not spin in sync with the left side.
I calibrated the radio again but the trims are off. Should I manually make 1100 to 1500?

Looking at the Rc1 and Rc2 output seems off, do you agree?

That graph says RCIN, not RCOUT.

You can fix the trim, won’t hurt but probably won’t change much. If you’re in FBWA it may be offsetting for yaw.

Also, make sure both ESCs are properly calibrated.

My last response was from my phone, after a few beers… So let me clarify a few things.

Throttle trims should be at your min value, so I’d change throttle right trim to 1100. But it won’t really change much.

If you have increased RUDD_DT_GAIN, then the throttles will change with the rudder movements. If you’re ground testing, look at what the rudder is doing. If it’s anything but straight then there will be a difference in the throttle outputs.

Maybe not related but I also suggest using SERVO_AUTO_TRIM,1 and making sure your radio trims are centred. In that graph you posted RCIN is showing RC1 level at ~1470. (I’m going to assume that if you’re using AETR that RC1 is your aileron input) Have you been using the trims on your radio? If so, that could be causing some of the trouble because the plane thinks it’s always being told to roll left, so with differential throttle the motors won’t spin up equally, and so on.

Do you have a .bin that you can share?

I tried ESC calibration this morning, and it turn out that one of my motor is burned out (its spinning but hesitating). I am going to replace both motors and than test.


1 Like