FBWA not obeying roll/pitch lims

Hi all,

For context:
I’m running arduplane 3.1.2 with elevon_output set to 3 and no elevon mixing on tx side. left wing is plugged into channel 1 output of pixhawk and right wing is plugged into channel2 (tried reverse but didnt work). The elevons are moving in the correct direction both in manual and stabilized modes.

Here is the problem:
For some reason when I put the plane into FBWA mode and demand full left on the tx I only get 25 degrees desired nav_roll instead of the 45 degrees I set (see attached images). The tx has 75% throw on both channels 1 and 2 and I’ve done the rc_calibration and I don’t think that’s the issue. Full left stick generates an rc1 input of 1179 and the recorded min rc1 value is 1177.

Any help would be appreciated! I can’t use the autotune feature until this issue is resolved as the plane barely turns in FBWA mode.

Here is a screenshot showing the rc1 limits.

For giggles I changed the max bank lim to 65 degrees to see if the demand nav_roll would change but I’m still reading a nav_roll of 25 degrees with max left stick. Seems as if somehow the bank limits are not being mapped to the rc1 input range? strange…

hi haogodent2,
This is a new feature in the latest release. You can read about it in detail here:
you can disable it as described on that page, but first be sure you don’t want it.
Cheers, Tridge
PS: I only just wrote this documentation page, so it is not surprising you didn’t know about this!

Ah, didn’t realize the stall prevention code is already incorporated, thanks for the clarification!!!

Quick corrections:
I am indeed running arduplane 3.2 and not arduplane 3.1.2.
The title for this topic is incorrect, pitch demand is working as intended.