Servers by jDrones

FBWA mode executes full throttle instead of reverse thrust


(Maxi) #1

Hello,

I came across a critical issue while groundtesting in FBWA mode.
The throttle input and output values are perfectly aligned as long as the throttle input is positive. However, when reversing, full throttle is applied instead of the correct reverse thrust value.

(0% throttle corresponds to a pwm value of 1333)

Reverse Thrust works perfectly fine in MANUAL mode. Tested on ArduPlane 3.8.2.

Is this a known bug in FBWA or am I missing something?

I have set the following parameters:
THR_MAX = 100
THR_MIN = -100
THR_PASS_STAB = 0

Regards,

Max


(lucamax) #2

How did you set USE_REV_THRUST ?


(Maxi) #3

USE_REV_THRUST = 2

Regards


(Paul) #4

I have the same problem, can somebody help me?


(lucamax) #5

Not sure but I think that USE_REV_THRUST = 2 is wrong , I read somewhere that the documentation is not updated.


(Kikislater) #6

Watch here :
https://discuss.ardupilot.org/t/auto-takeoff-and-reverse-thrust-not-working-after-upgrading-from-3-7-to-3-8/20262/12

I don’t update to 3.8.3 yet, but soon.
Pretty sure you have bad servo3 or rc3 settings. Post all rc3, servo3 settings to understand


(Maxi) #7

As far as I know, the USE_REV_THRUST parameter only affects the reverse thrust behavior in flight modes where throttle is auto controlled. However, throttle in FBWA mode, unlike FBWB, is manually controlled.

The params below are all my RC3 and Servo3 settings:

RC3_DZ = 30
RC3_MAX = 1929
RC3_MIN = 1331
RC3_REVERSED = 0
RC3_TRIM = 1333

SERVO3_FUNCTION = 70
SERVO3_MAX = 1927
SERVO3_MIN = 1175
SERVO3_REVERSED = 0
SERVO3_TRIM = 1333

Regards,

Max


(Kikislater) #8

In fbwa and with opentx rc, I could play with reverse thrust if I set my RC Param in opentx to -100 100. If I set 0 100 I have just forward throttle. I read on github that is the expected behaviour.
Rc3_min and servo3_min should be +/- same value IMO.


(Maxi) #9

Thanks for the hint!

I will try it out tomorrow when I have access to the plane and report if this solved the problem.

What surprised me was that instead of just not allowing for negative thrust and resting at zero, it went all the way up to full throttle.

Regards,

Max


(Maxi) #10

Thank you very much Kikislater!

Setting RC3_MIN to the same value as SERVO3_MIN solved the problem.

Regards,

Max


(Kikislater) #11

Cool ! Hope maiden was nice.
Which plane is it ? Mind you share video of reverse thrust landing ?


(Maxi) #12

I am flying a Skywalker X8 with retracts.
Auto takeoff went smooth but unfortunately it didn’t follow the waypoint mission the way it should. When I regained manual control it was too late. I will switch to a Bixler now to perform all the tests with pixhawk and once I get everything working correctly I will repair my Skywalker and of course share a video of the reverse thrust landing!

Regards,

Max


(lucamax) #13

Hello guys,

I’m trying to setup reverse thrust with a BlHeli Esc with last firmware .

My Esc is not arming , can you please post your Rc3 and Servo3 settings ?

The BlHeli Esc will arm only if the pwm value is about 1500 .


(Kikislater) #14

Sad, may be your elevons was wrong. With 3.8 and elevons you have to set it to AETR in remote now. Before this firmware, I had another setup with mixes which are not working with 3.8 fw.


(Kikislater) #15

Hi Lucas,
In Blheli suite, what is your PPM min value, PPM mid, PPM max ?
Also the key but not related here is to set motor timming to low in blheli suite.

RC3_MAX,2015
RC3_MIN,988
RC3_REVERSED,0
RC3_TRIM,1480

SERVO3_FUNCTION,70
SERVO3_MAX,2015
SERVO3_MIN,988
SERVO3_REVERSED,0
SERVO3_TRIM,1480


(lucamax) #16

Hello kikislater,

In BlHeli 1000-1500-2000, motor timing to medium.
I have activate brake function, found it in last firmware version of BlHeli, very useful for planes.

RC3_MAX,2000
RC3_MIN, 1000
RC3_REVERSED,0
RC3_TRIM,1500

SERVO3_FUNCTION,70
SERVO3_MAX,2000
SERVO3_MIN,1000
SERVO3_REVERSED,0
SERVO3_TRIM,1500

It works in both Manual and FBWA , but I wonder how to manage it, I mean I did not use any switch on the Taranis to activate reverse as some user did.

I was thinking about activate the spring of the Throttle in the Taranis .
Actually I had to lower the throttle to Arm with Arduplane the go to middle 1500 to arm the BlHeli Esc.

Also , would it work in auto modes ?


(Kikislater) #17

I manage it only in auto mode.
To avoid unwanted reverse throttle in fbwa, I just remove Low to mid in thr with this screen :

I don’t have taranis, but this scren looks like the same. This screen could have others names like output, servos, limits depending on firmware version I guess.
What you have to do is to set you throttle channel to :
CH3 Thr 0.0 0.0 100
With this setup you could arm in lower value.
Instead of that
CH3 Thr 0.0 100.0 100
If you have to arm, you could only in middle position

If you want to control it in fbwa mode, keep value -100.0


(lucamax) #18

I notice something unexpected .

Setting Rc3 trim to 1500 , set 1500 as pwm output for throttle even if in disarm state , so If the stick is in middle position I can arm and the go for clockwise rotation when going up with the stick and in the opposite direction for motor when lowering the throttle stick.

Setting Rc3_TRIM to Rc3_MIN set 1000 as pwm output for throttle even if in disarm state.
In fact with radio calibration use that set for RC3_MIN value.

I did a test flight but it is difficult to control the throttle that way for me so I will use a switch on my Taranis for the reverse action.

Thanks for help :slight_smile: