Servers by jDrones

FBWA and Q_ASSIST yaw control at low speed

Hi All,

Looking for some help please. I have a quadplane flying wing (with no rudder - elevons only). I have FBWA_MIN_SPEED set at 10m/s and Q_ASSIST_SPEED set at 12 m/s. When transitioning or flying at a low speed in FBWA, I would like to be able to conduct turns, problem is that the aircraft maintains heading due to Q_ASSIST (i.e it just sideslips), there is no yaw control from the quad motors. I have tried adjusting the various YAW2SRV options but nothing helps. Is there another setting I am missing

can you pls attach the bin file?

I guess so, but it’s not that there is a fault, I’m pretty sure it’s the correct behaviour, I am just looking for an override option … i.e airplane mode that allows me to yaw by use quad motors at low speed … might try FBWB or cruise mode. I’ll retrieve the logs

I think you need to set your FBWA MIN SPD greater then the stall speed and then set Q_ASSIST_SPEED @ or just above STALL SPEED. That way Q_ASSIST will kick in when needed (before a stall) but won’t effect FBWA flight.

1 Like

I agree with Steve, Q_ASSIST_SPEED should be lower than ARSPD_FBW_MIN. In other words, ARSPD_FBW_MIN should be above the stall speed and Q_ASSIST_SPEED should be below the stall speed.

If you don’t know the stall speed, then just set Q_ASSIST_SPEED to several m/s lower than ARSPD_FBW_MIN.

Good luck!

Thanks for the advice guys. I have done some bench testing and I’m pretty sure quad motor yaw assist is not available in any of the fixed wing modes (by design) no matter whether Q_ASSIST is active or not, I guess the intent is that if you want to manoeuvre at low speed you should switch to one of the Q modes.

Servers by jDrones