Faulty pixhawk motor calibration / stabilize issue

First time installation of a pixhawk on my tarot 650, and I’ve encountered an issue which I actually believe to be a faulty board - perhaps someone can weigh in. So here’s why in facing ;

Motor pin 2 and 3 ( both left side motors) are being over driven and spin much faster than motors 1 and 4. Before you say esc calibration - note that the calibration has been done both all at one and manually. When still in calibration mode, all motors spin up evenly as they should. However once I repower, that’s all out the door.

Another test I’ve done is to swap motors. Say I put motor 1 in motor 2’s position - the result is that it over drives motor one.

Yet another test is when I drop all my PIDs to 0, the result is that all motors spool up at the same speed.

This got me to thinking maybe the quad thinks it’s not level. I’ve done the acc calibration over and over and to confirm, the hid on mission planner shows a level horrizon when the quad is sitting level.

I have also calibrated the radio and the compass. There are no trims on my radio set. I also confirmed the props and motor direction.

Lastly. I put some props on and held the quad in a static test. It appears that the quad wants to level out immediately to a right roll, finally stabilizing at a 30 degree offset to the right. Meanwhile the horrizon on MP shows it is indeed crooked.

Any ideas or do I just have a bad unit out of the box ?

Please provide data flash log to help troubleshoot your issue.

I have exactly the same problem I’ve checked and calibrated but no change it’s a little upsetting seeing how pricey these boards are but maybe I just don’t have enough experience with pixhawk to see what is wrong.
Is there somewhere I can set trims on the board as all my trims on my transmitter are perfect.
I did notice one strange thing I had it on full throttle while gripping it in my hand, the battery eventually ran out and the failsafe RTL kicked in, it then went horizontal as it wanted to follow the command so maybe this is a communication problem between the radio and the board?

I’m going to try hooking it up to a different radio hope it works

Hello again I changed radios from my new Taranis plus to my old ORX T6 and problem solved

Sorry I’m still new to this forum thing the picture I posted before I’m putting with this post again is of a switch I noticed when I changed radios, it set the roll input to be controlled by channel 6. I disabled this but the Pixhawk doesn’t seem to notice channel 6 on the ORX T6 anyway . I have set this to disable and will change back to the Taranis and let you know if it makes a difference, but just to let you know it works so well with the ORX (I so happy it was user error and not the Pixhawk) now I just need to sort out the battery issue I’m only getting about 3 minutes with the 3 cell 5200 multistar

Ok so I’ve got to the point now where I’ve tried another radio which works but I don’t have enough channels to switch through my settings. I bought the Taranis so that I would have enough channels but there seems to be a communication error which puts the quad off by about 30 degrees. I’ve tried recalibrating everything even the ESC’s
Is there any way to adjust the difference between the radio and the pixhawk without messing with the subtrims because there is such a big difference that adjusting the subtrims means that I will not be able to roll left

please help I saw some one else with this problem on DIY drones so that makes 3 people with this problem

I’m guessing it’s a taranis calibration issue is there anyone with info on how to fix this

Ok just fixed it thanks to Pablo Neira on Diy drones forum he suggest checking the RC1_TRIM setting (it’s in the full Parameter list) and set it to 1500 mine was at 985 ( don’t know why but hey it’s ok ) so I set it to 1500 and now the problem is gone
thank you Pablo