Servers by jDrones

Faster, tighter turns for keeping front forward during Auto mission?

We have a multirotor that is carrying a hyperspectral imaging camera. We do auto surveys in Mission Planner, but because of the design of the sensor (line scanner), it is recommended that imaging is always done in forward motion (nose pointing forward, like an airplane would do), instead of the usual heading hold that make the copter go “back and forth” along lines.

When flying auto missions, what we see is that the aircraft starts turning (yawing and rolling) way before reaching the end of the lines, and does so very slowly. As this ruins the imaging, we would like the behavior to be more “tight”, with sharper, faster yaw turns when close to the waypoints. I have experimented with adding a 5 sec delay at each waypoint, which helps, but the multirotor is still very slow in yawing to the desired position, and still yaws after the waiting time.

Which parameters could I change to improve this, whithout changing how the copter responds during Stab/Loiter? And/or is there a way to program the mission so it goes “Get to waypoint > Stop > Adjust heading while not moving > Only move again once heading is correct”?

Thanks!

ATC_YAW_SLEW is what you would be looking for.
I had the same issue with messed up imaging with the slow turns.
A friend pointed out ATC_YAW_SLEW needs to be adjusted to a lower value for faster response.

See if you get the behavior you want out of that adjustment.

I believe earlier firmware was defaulted to 3000 Centi-Degrees and more recent was defaulted to 6000
But that is just how it felt to me before adjusting.

Hi,

Are you sure that ATC_SLEW_YAW needs to be adjusted to a lower rate? From my understanding of this parameter, a lower value means slower acceleration, hence a lower response, not faster (Arducopter params list).

Best,

Javier

My bad - yes, increase the rate is small increments (3000) till you find the desired rate.

I was thinking of what I did to get the results I wanted - sorry.

Thanks, I increased the value and it seems to be responding better. Only had the chance to do one flight though, will test more later, and report here for the record.

@pavan did you try this fix ?

Servers by jDrones