Failure to connect new Pixhawk - "No response from board"

As the title says, I have a brand new Pixhawk with a critical problem. Upon powering up, I hear the musical “everything is OK” sound, but the safety switch keeps blinking red. When I plug in the USB cable, the Pixhawk is recognized on COM9. The problem is that I cannot load any firmware on the unit, it fails to connect.

I have GPS, compass, safety switch, speaker, and power module connected, I have tried both the Wizard and the Firmware Update, and the stand alone firmware update tool. I all cases, the process gets to actually uploading the firmware and then times out with a message “ERROR: No response from board”. Or in some cases “Bootloader not found”.

I have updated the Mission Planner client to the latest. Uninstalled the application, manually deleted the PX4 drivers, then reinstalled the application and reconnected the USB cable and it successfully sees the Pixhawk in Windows. If I were to guess, I’d say it’s a bricked unit due to a faulty bootloader. Any help you can provide is much appreciated!

Here’s a video I made that may help:

It sounds like your Pixhawk is not being reset correctly by the MP which I have encountered occasionally.
You might try manually resetting the Pixhawk with the recessed FMU reset button that is located on the same side as the USB connection after selecting the firmware to be installed.
Also, you might try removing the GPS/compass module until you can successfully program the Pixhawk. Once programmed, then reattach the GPS/compass module.

Thank you, that does seem to allow me to connect! I’ve noticed that I need to do this every time I try to connect the unit to Mission Planner. Is there some way to just have it connect, rather than having to hit that reset button?

Are you running MP on a PC or a Mac? The Macs running MP seem to have the most trouble connecting with the Pixhawk.
You might want to try APM Planner 2.0 to see if that improves your connection issue.
I have found with one of my Pixhawks that I have to do the reset trick only when updating the firmware. Otherwise I wait until the end of the musical power up tones and then hit the connect icon on the MP to start the MavLink connection.

I’m running Windows 7 Pro 64-bit. I haven’t tried APM Planner 2.0, but I’ll give that a shot.

Still no dice on that, but I have figured out another trick to this: Don’t power the unit or connect to USB until AFTER you click the “Connect” button in Mission Planner. It will time out in 30 seconds, but that’s usually enough time for the Pixhawk to boot up.

It’s an odd issue, and doesn’t inspire confidence when this is going to control a $2k+ aircraft. But hopefully this is the only quirk with the unit, and everything else on it works properly.