Failsafe & SBUS not working?


I’m using Copter 4.0.5 official with Pixhawk 2.4.8 on a “X” quad copter, the radio is an HORUX X10 with X8R as receiver in D16 mode.
I tried to use the fail safe reaction available from Mission Planner.
I did :

  • Set of RX fail safe both from receiver (by F/S button) or Custom via Horus dedicated menu with a low level of throttle
  • I checked, via mission planner, if the throttle reaches the desired value switching off the transmitter.
    ==> Fail safe NOT engaged, the servo positions showed by mission planner don’t change
  • Set of RX fail safe both via Horus dedicated menu in order to have NO PULSES
  • I checked, via mission planner, if the servo positions come to blank
    ==> Fail safe NOT engaged, the servo positions remain not changed
    I tried to do the same connecting a servo on the throttle channel CH3, effectively it goes on the programmed fail safe position, or it becomes free in the case NO pulses.

I tried the same reading the output value coming from X8R (using a KK controller), the fail safe both for preset servo position or no pulses are working.

I suppose that there is a bug ?

Many thanks in advance

I tried to change the receiver, but nothing happen.
Nobody has suggestions ?

Thanks in advance

The No Pulses setting should work, but try this and see if it makes any difference:
A lot of radios/receivers go back to the how they were bound under signal loss conditions.
So you would put your throttle full down and trim down as far as possible too, or set something like -120%
Then bind.
Then set the transmitter throttle back to normal settings.
In the MissionPlanner radio calibration screen check that throttle output goes below failsafe level when you turn off the transmitter.

Regrettably the suggested procedure didn’t work.
I’d like write that I tried to check if the fail safe is working at receiver level, I did these checks

  1. One servo connected on channel 3 (Throttle), fail save set on receiver at min position then I put the throttle tick at maximum (the servo moved to the new position), switch off the transmitter then the servo moved to the the min position as programmed, I did this with two different X8R receiver.
    2 SBUS signal monitoring, I connected the receiver to a KK control board that permits on its lcd display to see the PPM pulse duration for each channel on SBUS. Switching off the transmitter the number showed on the LCD is MIN position, with transmitter ON the number showed follows the stick movements.

==> It seem that Arducoper software on my PixHawk down’t manage someting in a correct way.

Do you have any suggestion ?

Perhaps provide an onboard log with LOG_DISARMED set to 1.

Of course the FS_THR_VALUE has been set to a value below RC3_MIN and above the value that the receiver outputs when the transmitter is turned off?

If you set the receiver so that it outputs No Pulses (which is recommended) then MP’s Radio calibration screen should remove all the green bars when the transmitter/receiver connection is lost. If you do this then the FS_THR_VALUE parameter is not important as long as it is below RC3_MIN and below the minimum value that the receiver outputs when the user pulls the throttle low.

By the way, MP’s Servo output screen is not useful for checking the setup of the radio/rc failsafe because it shows the individual motor outputs which is not related to the RC receiver’s inputs.

2021-01-08 21-51-16.bin (732 KB)


I attached the log.
Red line = Aileron
Green Line = Throttle
I moved the Aileron from center to right then I raised the throttle to 100%, after this I switched off the transmitter (yellow circle to identify the area)
The fail safe it set for “NO PULSES”
After the transmitter switch off the expectation is that Throttle or Aileron go to zero, regrettably this doesn’t happen.
The unique message on HUD display on mission planner is for ARM switch, but I think that isn’t important.

I still available for any further detail

Many thanks

FS_THR_ENABLE is still set at 0, you need set it to 1.
FS_THR_VALUE is 975 , so I would set the transmitter to output less than 975 on the throttle channel, then bind.
Then I would reset the transmitter to the default calibration/output/trim so your output range is closer to 1000->2000 and redo the RC calibration. Then check the RC failsafe…

2 01-01-1970 01-00-00.bin (916 KB)


The Datalog is with failsafe on NO PULSES.

The HUD shows that fail safe has been engaged , the datalog too.

From my understanding the fail safe is working, please could you confirm me this ?


With Rx receiving signals

When I switch off the transmitter with fail safe set NO PULSES

Nothing is changed on servos output monitoring despite the indications from Randy (should remove all the green bars)

I’m doing something wrong ?

Please feel free for any other ask or further detail.


Yes that’s the same as what I get. I have just bound a new receiver (during very low throttle) and Taranis is set to No Pulses.

I’m using ArduCopter V4.0.5 on this quad.
Arducopter realises there’s no pulses (PWM or SBUS) from the receiver and enters failsafe, same as if the throttle channel goes below the set PWM level.

I have a throttle disable switch SF set to drop the throttle channel to 930 PWM or there-about.

  • With the transmitter on but throttle below failsafe level, the HUD shows RC Failsafe and MP radio calbration throttle bar moves to the low level (and Status tab, CH3out also shows the low PWM value, 930). After a few seconds MP HUD shows No RC Receiver.
  • With the transmitter switched off the HUD shows No RC Receiver and MP radio calibration bars dont move (nor does CH3out in the status screen, normal PWM value)

We’ve tested RC failsafe before and I think that should work as expected. I haven’t tested with this new receiver yet because of rain. It seems to be exactly the same operation as the X8R we were using.


That all looks good. I thought the green bars would disappear but I guess not. That’s fine though.

Thanks :smile: :smile: for the support !