Failsafe problem

I’m trying figure out why the failsafe doesn’t activate when I loose connection to my controller. When the connection is gone my receiver just stops sending the PWM signal to my APM. (I confirmed this behavior with an oscilloscope).

As far as I understand this should be the “No Signal” method described in the wiki. However none of the tests in the wiki seem to work. The log I’ve attached is of test #3, arming and giving it half throttle in stabilize mode, then shutting off power to the radio. The result is that it just stays armed and in stabilize mode. It seems to just remember the last values for all of the sticks.

Hopefully I’m just missing something simple here? I have another flight controller board (CC3D) and it detects the loss of signal correctly with the same receiver.

I’m using an APM2 with ArduCopter v3.2.1.
In the failsafe tab I have the failsafe mode set to “Enabled always LAND” but I’ve also tried the RTL mode with the same results.

Okay, now that I look at it closer my receiver (Fly Sky FS-R6B) is still sending PWM but only on two of it’s channels. Is it possible to only use the throttle channel as the failsafe?

Have you read up on “Radio Failsafe” on the arducopter website… I have my failsafe setup on a flysky receiver on ch3 (throttle)… … -failsafe/

It’s not difficult to do…

Sent using recycled packets…