Servers by jDrones

FailSafe on AUX pins


(Toto Mauris) #1

Its possible to move FailSafe pin on AUX pins ?

If yes, how ?

Thanks in advance,

Have a nice week-end.


(Hunt0r) #2

Maybe others do, but I’m not sure I understand your question. What do you mean by “FailSafe pin”?

http://ardupilot.org/plane/docs/apms-failsafe-function.html


(Toto Mauris) #3

I would like that when I send a pwm signal to an pwm input aux the controller turn into failsafe mode


(Hunt0r) #4

That behavior is not directly supported by the FailSafes as described in the linked documentation.

However, here is a workaround that might suit you: Configure your Transmitter with a throttle shut-off switch, which drives your throttle PWM signal BELOW 0% throttle. Thus when you flip that TX switch, the TX sends a throttle value below 0%, and trigger’s the Throttle Failsafe as configured in ArduPlane.

(For example: My 0% throttle is around PWM 1100. I set my throttle FailSafe parameter at 975, and have my shut-off switch send ~950 corresponding to less than 0% throttle. This activates my Throttle FailSafe behavior.)


(Toto Mauris) #5

In fact, I’m using an ppm encoder and failsafe doesn’t work, that its why
I’m trying to set failsafe on an aux pin


(Hunt0r) #6

Maybe someone else can think of a clever workaround? I don’t know one.


(James Pattison) #7

The ppm encoder should just pass through the failsafe behavior of your receiver, so if you can, change your receiver settings. You need it to output a low ch3 signal on loss of link, not no signal or hold last signal, then set your throttle failsafe value a little above what your receiver outputs on link loss.


(Toto Mauris) #8

Thanks for help, but I can’t change receiver settings.

My remote is radiolink AT10, receiver r9d


(James Pattison) #9

Google suggests this could help. I don’t know radiolink gear.
https://www.rcgroups.com/forums/showthread.php?2390481-RadioLink-AT9-bind-and-fail-safe

Regards,

James


(Toto Mauris) #10

Thanks for your help, but I use an arduino nano on one of the pwm receiver output I can’t use SBUS, I must use ppm encoder


(James Pattison) #11

You could use sbus, and connect the arduino to a pass through channel on the Pixhawk


(Toto Mauris) #12

Could you explain how to do the passthrough ? (Patameters)


(James Pattison) #13

Just set the servo output param to match the input channel you want to use.

http://ardupilot.org/plane/docs/channel-output-functions.html


(Cindy Nshuti) #14

Hi,
Have you tried to set the failsafe on your Rx rather than through your Arduino Nano? Here’s a link you can try:


(Toto Mauris) #15

I have tested the procedure post 5 https://www.rcgroups.com/forums/showthread.php?2390481-RadioLink-AT9-bind-and-fail-safe

The procedure works with AT10 and ppm encoder (not only with Sbus receiver)

"

  • Turn on transmitter and go to failsage options
  • Select throttle, next select failsafe
  • One time you have selected failsafe, lower down the thottle, then long press on Ok (push buttom), it will shows you 15%

Your failsage is set to 15% signal before send the failsage signal to FC
When failsage is set on transmitter with S-BUS, even if you lower down throttle you will always get signal and a higher value than transmitter turned off, so you can not set a PWM value with the 10 unit above the throttle lower and 10 unit lower that the value when transmitter is off.
So I only set it when transmitter is turned off

*Connect drone to MissionPlanner
*Go to Failsafe settings
*Play with throttle if everything is fine you will see it moving
*Turn transmitter off and copy the throttle value when it is off to the failsafe value panel and always enabled RTL or continue mission if you want…

"


(Toto Mauris) #16

My transmitter allow to send RSSI value on CH 6 to 10.

Could you say if its possible to select CH used by failsafe mode… ?