Failsafe caused CTUN.ASPD dropping and throttle increasing to 100% and crashed

Hi guys,

My Ar Wing Pro maiden crashed due to weird RTL response when failsafe. The wing uses Arduplane 4.0.8 on Matek h743 wing. The takeoff and autotune works perfectly. After that, I started an auto mission. During the mission, it triggered failsafe. Then the airspeed started dropping (no airspeed sensor and GPS ground speed is fine) and FC increased throttling to 100%. The wing started oscillation and crashed due to lost of control.

Here is the video. The first 10 minutes is perfect. The issue started at 10:30.

Here is the bin and log file.

From log, it seems CTUN.ASPD started dropping and caused throttling to 100%. The CTUN.ASPD looks strange.

Please help me root cause this issue.


Without looking at your logs I will give you my thoughts of what I think happened. I am going off of my experience with my plane.
When rtl is triggered the plane rtl_climb_min which kicks in throttle_max until its done climbing. Then the autopilot looks to see what your rtl altitude is set to and then if it’s lower than the current altitude throttle_min kicks in and the plane glides down to the rtl altitude. During one of the throttle_max events the pid controller could have got overwhelmed.

How long did you do the autotune for? Did you preform autotune at different throttle position? Meaning maybe the pids where set for the plane at half throttle and when rtl kicked in it didn’t know how to handle the oscillations at that speed.

So when the crash happened did the rtl just kick in?

1 Like

I don’t think your tune ended up as good as you had hoped. I had a similar problem with an AR900 wing, that after autotune I would get violent pitch oscillations. I ended up manually tuning pitch (actually leaving it pretty basic tune) and that kept me out of the pitch oscillations. Like yours, the oscillations wouldn’t happen all the time, but when they did occur it was violent.

I would suggest resetting the PID and working through a manual tuning procedure.

One other thing I noticed was during your autotune run it looked like there was full deflection on roll and pitch at the same time. Or going back and forth between one and the other. You may get better results from doing just one at a time.

1 Like

The synthetic airspeed is up to 23:58:00
completely correct. After that, it erroneously goes down to 0 m/s. Assuming a low speed, the amplitudes of the rudder servos are increased, which then leads to flutter at the actual high speed (20 m/s).

This explains the fluttering, but not why the airspeed is determined too low from 23:58:00 onwards, which is completely incorrect.

Contrary to previous speakers, I am of the opinion that the autotune was successful.

But I have no idea why the synthetically calculated airspeed was suddenly so wrongly low.


1 Like

Thanks for the analysis. Autotune runs for 5ish minutes. I did run turn right/left and up/down 20+ each and each turn over 2 seconds. I did not run autotune for 100% throttle, only run for the middle throttle. Do I need to autotune for full throttle and all range of throttle?

The issue seems related to radio loss failsafe wait time finished when I review the video I can hear the beeper beeping when lost of radio.


I double-checked my RTL settings. Both FS_SHORT_ACTION and FS_LONG_ACTION are set to 0. So it continued the auto mode and did not change to RTL mode. So the full-throttle change was not triggered by RTL. It looks more likely the synthetic airspeed dropping caused throttle increasing.

Thanks for the info. Good to learn ar wing oscillations issue. I will pay more attention for my next ar wing build. waiting for banggood 2 weeks shipping now.

Yes. The airspeed looks strange. Do I need to add a air sensor for this case? Or is this some regression bugs in 4.0.8 version?

To answer your question about autotune at 100% throttle, it’s doesn’t need to be 100% but i would say at least two different throttle levels. I would shoot for where you plan to spend most your time and maybe 75% or more throttle.

I’m sorry that your plane died young. It is never easy to experience an early demise.

The autotune would produce a good flying airplane, but the only way I could deal with the oscillations was to dial back the tune manually. The AR wing is the only plane I’ve had that problem with. Other wings and regular planes I’ve tuned haven’t had an issue.

When tuning I set a cruise throttle position, or sometimes a bit higher than cruise. You will invariably loose some altitude during the tuning so some extra throttle will help. I’ve never considered it before, but maybe on the wing tuning with higher throttle may give you a better high speed tune. That’s pure coffee fuelled morning thinking so take it for what it’s worth. I’m not sure it would make a difference.