Failed to initialize the sensors

Hello i’m the one who uses the arudpilot and emlid navio2 hardware with RPI2.
I’m using the latest ardupilot software (2017.3.4 commit 2631bdbe64e32a9607bda642125a87f5979aafc6)
(Just in case, u need to build with ‘waf --targets bin/arducopter’ not 'waf --targets bin/arducopter-quad)
Actually the issue i’m trying to mention is irrelevant with the software version.

Anyway, whenever i run the ardupilot software on the RPI with Navio2,
i suffred some sensor failure like barometer when the ardupilot initializing, very often.

And when i initially calibrate the drone with mission planner or APM planner,
the software does not work with errors like AHRS failure, and any other error with barometer.

Therefore, at that time, i really search the web, but i can’t find the solution and it just worked after several tries.
Now, i think i figured out the source of error. It’s the hardware-wise problem, not software.
As you see at the image below, now i make the board float a little bit with dumping ball.
I didn’t have those dumping balls before, so i just made it stick to the substrate screwing it to the substrate.
I think the RPI with Navio2 leak the current to the substrate or interfered by the substrate, sticking to the substrate.
Therefore, the value of the barometer or other sensors on Navio2 does not work properly.

In conclusion, i’m just writing the article wishing there would be no one suffering the same problem like me.
Because i saw some same issues here around with title “Failed to initialise ADNS3080” Problem”.
I guess it’s also same issue.

Have you contacted Emlid to see if they can help?

Thanks, Grant.