Servers by jDrones

"Failed to init cube Black" after update

Hi everyone!

So today, after doing a regular flight, I have tried to update my quad to the latest version (from 4.01 to 4.03).

The installation (using mission planner) has not been problematic except at the end. When it says “wait for the tune before OK” I’ve waited for around 2 minutes and the buzzer has not made its regular sound. I’ve thought that the buzzer might have sounded earlier without me noticing it so I`ve clicked OK and proceed to reboot the Cube.

So now, when I power the cube (USB or battery) the buzzer does not do the initial sound and in mission planner it says “Check BRD_TYPE: Failed to init CubeBlack - sensor”. BRD_TYPE is se to 3. I have tried to reboot it multiple times, flash older firmwares and nothing.

I’ve checked the HW ID page and this is what it shows. Isn`t the barometer missing?

It is a pixhawk Cube Black that I bought nearly a year ago. I have updated the firmware multiple times with the same computer and I have never had a problem. Anyone knows the cause and how can I solve it?

Thanks in advance!

Good day, after you connect it…, before the firmware update did you accept the request about the board black cube?

Yes, the first time I updated the firmware I had to confirm that my board is a cube black, and then disconect the board, press ok and reconect the board.

Did you check also flash a custom firmware file?

No, I have not. I have nevered flashed a custom firmware file so i dont know much about them. Which should I try?

I’ve checked the HW ID page from a similar drone and the only line that I am missing is:
MOT_BAT_IDX devid 0 bus type BUS_TYEUNKNOWN bus 0 adress 0 compass 0 or devtypeimu 0

https://firmware.ardupilot.org/Copter/stable-4.0.3/CubeBlack/

Just download the .apj, install it with MP using the option custom firmware

Same problem as before.

Update:
So i iunplugged my gps, my telemetry and instead of my buzzer + USB I installed a simple buzzer and connected directly into the cube. After two or three firmware updates with the same result, I have finally managed to get a succesful firmware update. Now I have a working cube but with 3.11 firmware. I am not sure if I want to try to update to the latest firmware, I dont undestand what happens with my cube.

Do you have the last MP and drivers? can you send me pls a pic of your cube?
Did you try also QCS?

Yes, I’ve the latest MP and drivers. In fact, I’ve tried with multiple computers. And yes, I have also tried with QCS.
It is a very narrow chasis, if you tell me which part of the cube you want to see I will try to take a photo.

I have the same issue… Was working and I decided to update.

I notice that If I try to flash the same version again, it says that is already on the board and it boots…

Does anyone knows whats hapening?

When trying to flash the second time I have the message “No need to upload. already on the board.”

Ok, I don’t now why it worked, but…

I have downgraded the firmware to 3.6, then forced bootloader. It was working, so I updated 4.0.3 again and voila… Now its working kkkkk

Servers by jDrones