Failed to Disarm

Today I was out doing a test flight after loosing an ESC in flight.
I was basically taking off landing checking for heat and taking off again.
I wasn’t watching the battery status and got a battery fail safe. The fail safe I understand from reading the logs and have taken steps to correct that. But when the machine landed, it kept the props spinning till it eventually tipped over. I assume it didn’t know it was down.

I kept trying to disarm but no go. Finally it crash detected and disarmed. But I was afraid of getting injured, injuring someone else or at a minimum damage to the machine.
I was just about to kick it over on it’s top so I could pull the battery but the disarm solved that. I can’t have a machine that won’t disarm so any input would be appreciated.

Use disarm-on-a-switch. Or motor-interlock-on-a-switch. I use both.

Hey Peter yes I am just reading about disarm and kill switches. I Can’t have this happen again.
But I still want to understand what happened.

Your vehicle was trying to navigate.

This was keeping the motor outputs above the landing detector’s thresholds.

Now as to why it was trying to navigate - there was a bit of stick input prior to the divergence of target and achieved position:

So essentially the vehicle was trying to be somewhere else while it had its legs on the ground.

Note the GPS glitch here. It definite wouldn’t have helped - but I think it was probably the late stick input which did it in.

ah interesting. So the RTL was going reasonably well…however it was windy and the bird was not tracking real well…it would not have been a problem but it was coming down close to a building. So I gave it a quick nudge to the right to keep clear of the building. I did that while it was still clear of the ground.

I assume your telling me it was trying to get back to the location I took it from, but it’s feet where on tera firma and the motors where still running to high to be considered landed and so it tipped over trying to navigate back

… Is that correct.

Also that doesn’t explain the disarm issue, unless you can’t disarm in flight…but does potential explain the nose over.

I’ve seen this on occasion too, when you get those GPS glitches right before landing.
We have set RC{x}_OPTION,31 - Motor Emergency Stop. Arm to spin the props without taking off then hit “the switch” to make sure it works as expected. This is peace-of-mind for those new builds and probably best left in place indefinitely anyway.

You were still in RTL mode too, so maybe switching to Stabilise and holding throttle down would have helped but I cant be certain without testing that.

Hey Shawn @xfacta
I did switch to Stab and tried to disarm…No go. I assume you can’t disarm in the air, which I think the machine considered itself. I can’t find any documentation that states the logic around disarming but I either way I could not disarm.

The thing that is annoying me the most is the GPS glitches. I suspect had there not been a glitch this post never would have been started, I wouldn’t got as far as saying I am plagued by them…but I do get a lot of them.

USB3.0 causes GPS glitches. Are you using that? Move GPS antenna away from interference sources.

No it’s a pixracer using regular USB.
But will keep that in mind.