Failed compass calibration


We have a problem with the compass calibration, sometimes the callibration doesn’t start at all and a few times it has started but it stopped at a certain percentage. We don’t know what the problem is or how we can fix it.

Thanks in advance

Drone Swarm

If you want help you need to provide more info about your problem. Start with the picture of your setup, information about arducopter version type of compass etc.


We are using an build in compass from the “Micro M8N GPS”, which is the “QMC5883 digital compass”. The arducopter version we are using is 4.1.5, also the FC we are using is Matek Flight Controller H743-MINI.

Picture of our setup:

Post the parameter file. I don’t suppose you have a Flight Log w/o a calibrated compass.

Did you follow the steps from:
Did you select as primary on the top external compass in Mission Planner ?
Did you select only external compass or more ? This Matek has build in compass on the board ?

No Matek Flight Controller has an on-board compass.

if you are using ArduCopter 4.1.5 why did you post this on the ArduCopter 4.0 category?

This is the parameter file you asked for but we don’t have a flight log Parameter File Drone Swarm.param (20 KB)

Set COMPASS_LEARN back to default (0)

Yes we followed the steps that are on the website but sometimes the calibration doesn’t even start or is stuck at a certaine percent. We are using only one external compass from the GPS.

This is what wehave selected when doing the callibration.

We did it, but it stopped at 23 percent for some reason, this has happend before and we don’t know why it is doing this.

How are you doing the Calibration? Rotating it around in all axis?

Relax the Fitness and see what happens.

Yes, we are doing the calibration by rotating it in all axis, i tried relaxing the fitness but i doesn’t work because When i start the callibration in get stuck on a random percentage and it doesn’t proceed anymore.

Faulty compass possibly. I have that same flight controller and no problems.

Try QGroundControl and see if it will calibrate.

I tried it on QGroundControl but it still isn’t working, but it is my first time installing and using this software. But i tried the calibration multiple times and i doesn’t work.

Not sure what else to think other than a hardware problem. Obviously it’s communicating on I2C as it’s being assigned an ID.

Did you hear the fault voice from the copter. During calibration you should hear bip bip and when fault occurs special sound of the fault ???

No while callibrating there isn’t any sound from the copter, i doesn’t make any noice. But before this we had a other GPS (so other compass), back then the compass callibation sucseeded, but we also had some problems with callibrating back then (same problems, but after a while it completed) and the drone didn’t make any noice while calibrating with the other compass.

1 Like

Yes, we have been searching for a while but we just can’t find it.

1 Like

Hi Drone_Swarm, I am also facing the compass calibration issue on my pixhawk 2.4.8 board with arducopter pixhak-1 firmware. If you had fixed the issue can you please reply how or provide an alternative to atleast fly the pixhawk without compass?