F405 Wing telemetry problem

Hi, I am back with a problem regarding my SpeedyBee F405 Wing FC, more specifically, connecting via the telemetry radio.

After uploading latest beta firmware, I can connect the Flight Controller to Mission Planner via USB port, but can’t connect via Telemetry Radio. LED’s on both devices are lit up, not flashing, which would mean they are connected to each other, but for some reason Mission Planner can’t connect, all I get is “trying to connect” and it counts down until the timeout. I tried some fixes i found (like switching RX and TX pins on the telemetry connection, different baud rates), but none of them worked for me, can someone give any advice what to do? I can provide more info if needed.

Kind Regards,

I suppose you saw this.

I saw this, but from what i know, the wireless connections like Wi-Fi and Bluetooth are for connecting w/o radio telemetry, so i don’t think that is the problem.

I assumed you were using the integrated radio. What Serial port do you have the telemetry radio connected to?
AC Doc

Do you mean where is the telemetry radio plugged in on the board, or on GCS? I don’t really understand what do you mean by the “Serial port”

ok, after some reading i think i have it connected to SERIAL6, if it helps, I Soldered the cables to the Solder pads

I have yet to get this to work either, both on wifi or bluetooth.

But have you tried using external telemetry radio? Thats where I’m experiencing the problem.

Did you read the Arducopter Wiki page? The internal radio is on serial6.

So, use another port for an external radio.

After even more reading, i came to a conclusion that my external telemetry radio is actually most likely connected to Serial 4 port, because the solder pads on the board say “R4” and “T4” which, I think, correspond to Serial 4. After changing SERIAL4_PROTOCOL to 1 (MavLink 1) or 2 (MavLink 2) On Mission Planner via USB, I still can’t connect to the board via Telemetry, am I missing something?

Also sorry for all the mistakes I make, I can fairly say that I’m still pretty new to these new devices, I didn’t need to setup these Serial ports on APM, so I don’t really know how to do it.

Alright I figured it out (I had SERIAL4_BAUD set incorrectly) and got It working , yay! Thank you so much for help Dave!

Glad to hear you are advancing!

1 Like

What did you set the Baud to to get it to work? I am experiencing a similar issue.

The 57 setting (which is 57600 baud rate) worked for me.

Hmmm interesting. Do you mind looking over my post to see if anything jumps out at you?

Telemetry Issue