F405-Wing: How to connect GPS to UART4?


I am tring to wire my plane by sugguested “F405-WING General Wiring figure” (http://www.mateksys.com/?portfolio=f405-wing#tab-id-3).

This figure is for INAV, I am using ardupilot with Mission Planner. I would like use Serial 4 for main GPS, as shown in above figure.

When I connect my GPS to UART3, everything is fine. I got a “NoFix” message cause I am indoor.
When I connect the same GPS to UART4, I got “NoGPS” message.

I tried to modify parameters below:
SERIAL3_PROTOCOL 5-> -1 disble gps@Serial3
GPS_TYPE2 0->1

What shold I do?
Thanks a lot

Did you set the SERIAL4_PROTOCOL to 5?

I don’t think you need to adjust with GPS_AUTO_SWITCH or GPS_TYPE if you’re only using one GPS module. Those adjustments are only required for multiple GPS.

Why use an iNav figure if you are using Arduplane?

Hi, I just cannot find figure for Ardupilot. Do you have any suggestion?

I found my GPS module is broken, I got a new one today.

And also, I got response from Mateksys, quota “GPS can work on any spare UART-TX & RX. If you connect just one GPS, DO NOT enable GPS_TYPE2, GPS_TYPE should be still 1, then set SERIALx_PROTOCOL = 5 on corresponding UART”

But it is quite strange, I use the same cable, same GPS module, connect to serial3, 4 and 5. Only serial 3 has GPS noFix infomation. Both serial 4/5 show noGPS.

My settings are attached, do I need change other settings?

And another question is : the GPS module is 9600 Baud rate, I do not know why 38400@serial 3 works.

What kind of GPS are you using? They usually default to 9600. (I’ve never had to mess with baud rate on any GPS module)

Sorry if this question is too obvious, but do you have the TX/RX wires correct? (TX -> RX, RX -> TX)

It works because the module is configured on Flight Controller boot. With default parameters anyway.

PXL_20210203_095452576 PXL_20210203_100038331

My GPS module is G28U8FTTL, as shown in photos. I think my connection is correct, the blue wire is TXD in GPS side, the green one is RXD.

Hi, thanks everyone. I found the sulotion:

I set SERIAL3_PROTOCOL, from 5 to -1, in order to disable GPS on serial 3. As suggested by Mateksys engineer. Now GPS works on UART4 finally.


Matek support has come through for me in the past too. They know their stuff!

Your are right.
I did try this solution in the very beginning, but my GPS module is broken at that time :rofl: