External LED's with Mavlink

Hi, I have an external LED board that runs from the telemetry port (Port2) on a Pixhawk 2.4.8 but the LED’s are not getting the info they need to signal change of status and low battery flashing yellow ? they worked in the old copter software but not 4.2, is there a parameter setting i need to update/change ?

Thanks, malc

You will need to change the SR2_ Parameters to something other than zero so the data is sent automatically without being requested, I assume your running in half duplex mode with only a single tx wire from pixhawk to led controller. you might have to also set it to mavlink 1 mode by setting SERIAL2_PROTOCOL to 1.

Yes changed all the parameters and still not working, is there a missing parameter form an older version of copter ? the LED’s worked fine in 3.6.8

what led board are you using and how have you wired it?

It’s like the one on this website.

Pixhawk Mavlink External LED Controller for APM Pixhawk2 Ardupilot PX4 RGB Navigation Light Quadcopter Hexacopter Drone Plane – Grandado

post a log file from the flight controller. are you sure you have changed the serial port to mavlink version 1 by setting serial_protocol to 1?

Link for file


try changing serial2_baud to 57.

yes i have changed to different baud rates.

set serial2_options to 0 with serial2_baud to 57.

OK, Done that but no change ? i’m going to check the wires into the crimps to make sure there is connection/data flow.

Sorted, i had a bad crimp connection on the TX wire from Serial 2 to LED control board, all working fine now, thanks for the help.


1 Like