Servers by jDrones

Expresslrs receiver issues on channel 5 for mode change (SOLVED)

Hi,

I connected a expresslrs EP2 receiver (happymodel) on UART2 of a CUAV V3 (fmuV3 hw). I have set the serial protocol to CRSF (23) in mission planner.

The first 4 channels (A, E, T, R) are received correctly. Channel 5 however only sees the minimum or the maximum PWM value (seen in the radio calibration screen of mission planner).

I also receive some telemetry on my TX from the receiver.

Is this a know bug that channels above 4 are not received/read correctly ? Or did I do something wrong ?

I’m pretty sure there are issues with Expresslrs, @yaapu would know more

I don’t think its a bug it’s odd implementation. Did you read thru the Wiki? This section for example.
ELRS Mode

I looked into ELRS for my R9 stuff (have a lot) and determined it’s not ready for prime time with regards to telemetry. BetaFlight users, have at it…

Like that Lumenier Flight Controller you bought? Perhaps, wait…

Edit: I think I’m wrong about the channel five stuff below. Thanks for the link @dkemxr

To speed up the packet transmission, ExpressLRS reduces some channels’ resolution to a single bit. Some channels (I think channel 5 is one of them) only has two possible values.
IIRC the latest version of ELRS requires the arm channel be on a specific channel. I’m not positive, but I think channel 5 is the arm channel and this is limited to on or off.
I heard this info in one of Joshua Barwell’s livestreams.

You are right, but maybe it’s chan 8 you need for Ardupilot modes?

I’m just barely getting into ELRS myself. I just recall hearing one of the channels was being reserved for the arm switch so there wasn’t an added delay in the ability to stop the motors.

I’m guessing low latency in setting the mode is also pretty important based on some of the ArduPilot examples I’ve seen.

That is the answer ! That explains why I get only two positions of minimum and maximum PWM values on that channel 5.
I wil ltry to use another channel for the mode change.

Thanks !

Thanks for the ELRS Mode link. That explains it all. and solves my issue (which was to be able to change modes on channel 5 but I’ll do it on another channel then)

You should probably change the Title of the post. It’s not an issue with 4.1.0 or how it’s recieved by the Flight Controller…

Done. Title is changed.

Thx

Servers by jDrones