Expresslrs epp2 Matek f405-wse issues

Totally new to Ardupilot. THought I’d give it a go but cannot for the life of me get my tx and rx working. 4.0.9 firmware loaded to board.
Tx16s running Elrs 150hz TLM 1:16

Calibration of board worked, but not a thing workng on Radio page.

Epp1 Elrs rx conected to Uart2 on matek f405-wse board.
Serial7_Protocal = 23
Serial7_options = 4

Spent 6 hours on this getting nowhere fast.
Any help greatly appreciated.

Updated to latest version firmware and set Protcol = 29 and it’s working know.

1 Like

Ongoing issues… Updating has not fixed the problem.
Reflashed board so that I start with a fresh firmware install.
set Brd_alt_config = 1. radio was detected and started working.
Serial7 = -1 !

Disconnected/ switched all off then reconnected and Radio was still working.
A win…

Just swithed everything back on after 5 min and the radio is no longer recognised. No movement in calibration tab at all and I’ve changed nothing.


NTOFT, did you ever get this working? I’m trying to configure a Matek F405-Wing, Ardupilot, and ExpressLRS EP1 on Serial5, and having no luck at all. I configured it based on this

and since have tried a bunch of setting variations, none of which made a difference.