ESP8266 Mavlink

Hello team,
I’m at my whit’s end here. I cannot for the life of me get this working ! Yesterday it worked once or twice now today nothing.

ESP8266 with speedybee f405v3
I have the wifi status page open and packets being counted but no setting I have tried end with it connecting.
I can connect immediately with USB every time.
I have allowed MP and arducopter.exe through the firewall.
I’m using UDP.

I’ve read dozens of similar complaints in the forums but most end with no replies or solutions. How can I troubleshoot this issue?
Thanks for any help.


Hi Michael,

On your picture you can see that the ESP8266 does not receive any data from Ardupilot. (Packets received from the vehicle = 0 )

Check frequent carelessness:

Is the Esp8266 connected to the correct serial port ?
Is the serial interface in Ardupilot set to mavlink2 ?
Are the Rx/Tx lines cross-connected?
Does the baud rate set on the flight controller match the baud rate set on the ESP8266 ?

Good luck

Which actual ESP8266 module is it? You want 921600 baud. I use the $1 ESP-01S modules across several FC’s and they generally just work. Some of these cheap modules you have to pull the EN/CH_PD pin high so I just solder a jumper in all of them.

Thank you both for your replies.
As I said previously, It worked just fine then stopped. all within the same hour.
Now, when I wake up this morning I try again, and it instantly connects.
I need to narrow down what the issue is, is it my pc, is it the mission planner software, is it the FC, is it the Radio, is it the power supply etc. Be nice to know exactly what is going on when it fails to connect. That screenshot from yesterday is not really all that helpful because after posting I was getting 3 or 4 packets from the vehicle in the 30second countdown. So something is flowing but clearly not quickly enough, it then times out. The error message sems so generic, I need more detail.


If it works and seems NOT stable, please lower the baudrate and check physical cable connections.

@MichaelM Can you share the versions of

  1. ESP8266
  2. Mission planner
  3. Mission planner is On windows 11 or 10?

As I can’t connect to ESP8266,64bit Windows 11 + MP 1.3.81 Can't UDP connect 8266WiFi module (v1.2.3) · Issue #3356 · ArduPilot/MissionPlanner · GitHub

Thanks for your reply Daniel.
I’m using this board, details are light but it’s the first one “V3 not Soldered”.
Wireless Module CH340/CP2102 NodeMcu V3 V2 Lua WIFI Internet of Things Develop Board based ESP8266 ESP-12E with PCB Antenna (

The firmware was flashed with the "firmware-esp01_1.bin from ardupilot firmware repos.
Version: 1.2.3
Git Version: 34a2158c43c626f6bd7740bae22b25091d6f1bcd
Build Date: 2021-10-15 19:42:50

MP: 1.3.81 build 1.3.8741.25556

Windows 11

Edition Windows 11 Pro
Version 23H2
Installed on ‎08/‎03/‎2024
OS build 22631.3593
Experience Windows Feature Experience Pack 1000.22700.1003.0

All this morning it has been stable, some 2.5 hours connected now and persisted multiple FC reboots.
Will see how it goes over the next coming hours through further testing and set up. I’m scared to reboot my pc though.

Thanks for the info, I finally got it fixed. It’s firewall issue.