ESC's keep catching fire

I am new to multi-rotors and have just built an S550 running APM 2.6. Today I finally managed to get it off the ground and into a hover but I have now had 3 different ESC’s catch fire spectacularly. First two were on ground testing while spinning the props up and third was today after a crash landing in a bush. After the crash landing all seemed to be fine so tried a second take off, it hovered for about 5-10s then after switching to loiter mode, motor 5 cut out and the ESC burst into flames.

Does anyone know what could be causing this?

I am running the following…
APM 2.6 with power module
5000mAh 4s
30A SimonK Mystery ESC’s (black)
EMAX MT2216 810kv motors
1045 props

Do you know the maximum voltage rating of your ESC’s? I can’t find any info on it, but it could be that your ESC can only be used with up to 3s LiPo, so your 4s kills the ESC.

Maybe losing sync. I had a particular motor/ESC combo that, when it lost sync, would burst the motor and ESC into flames.

I am experiencing something very similar and cannot figure it out
Standard X Frame, 4 motor Quad System
Smoking ESCs on Arm #1- 2nd set of ESCs and Motor same result- Up in SMOKE
So I am completely baffled, we have 2 quads almost identical, one flys perfect the other has not seen more than a couple mins of flight because the ESC on Arm 1 start smoking. I changed both the motor and ESC and got exactly the same result, another smoked ESC. I did bench testing to make sure everything works correctly before putting it into the air (rotation check, ran up to ½ throttle without blades) but I am now wondering, am I in a bad batch of ESCs – hard to believe as both sets are different brands. Is it the motors, hard to believe as these are DJI 2212 motors but they are not at all what I would call high end. All ESCs have been calibrated before throttle up. 1st ESC burn was on the bench with very little throttle, 2nd ESC burn was in flight about 2 mins into first flight with new ESC and Motor.

APM 2.6 external compass
Ardupilot power module
Futaba 6ch receiver & Transmitter 2.4G
SimonK 30 amp ESCs
DJI 2212 motors both CW and CCW
DJI Self Tightening Props

Thanks for any thought on this, I am wondering if stems from a signal coming from the Arducopter 2.6 only because it is happening on the same #1 arm. My other quad is running sunnysky 2212 motors and flys great.

No there is not a make the ESC burn setting. Make sure you have properly configured your speed controllers and power wiring.

Thank you, I am not sure exactly what else is needed.
"Make sure you have properly configured your speed controllers and power wiring."
The ESCs are put in the correct positions 1-4, the calibration is done with throttle stick up, power connected / disconnected and reconnected - lower throttle get the beeps.
As to the power wiring, I am using a common buss system that each power and ground lead come off a plate- each motor wire is soldered to the plate.

Do you think that the power distribution I made might have a influence because of a solder joint or something?

This morning I flew the quad for about 4 mins, I saw smoke come off the #1 esc but the quad continued to fly, so I went with it. At about the 4 mins time the #1 motor stopped and with the self tightening props, threw a prop. The ESC was hot enough to shrink the wrapping even more. When I checked the inputs wires the were at room temp but the ESC was blistering hot. Bench test without the props, #1 no longer works,

thanks for your help