Servers by jDrones

ESCs don't initialize

Problem: When I connect the battery, I hear the first three tones (ESCs have power) but not the second two, which I understand means that they are not communicating with the FC. I have tested, and I can’t get the motors to spin with MissionPlanner motor test.

Setup: Omnibus F4 Pro flashed with ArduCopter 4.0.3 (same problem existed on previous versions). Racerstar 35A Anniversary 4 in 1 BLHeli_S ESC. I also don’t have a radio receiver connected. But is this necessary for the ESCs to start up properly and to test motor rotation in MissionPlanner (so that I can confirm correct direction, etc).

The ESCs initialize properly, and spin the motors, when I use a servo tester. I have tried selecting different protocols such as “Normal” and different DShot protocols (150 and 600). No difference. I tried lower the pwm min output without any luck. ESC calibration doesn’t work as described. Tried to configure BLHeli passthrough, but BLHeli Suite can’t find the ESCS. I wanted to tinker more but now for some reason my PC and FC don’t want to connect, and I need to troubleshoot that problem. In the meantime I thought I’d ask if anybody has a suggestion for what I should have a look at.

Many thanks in advance!

You need to get pass-through working. Then turn off low throttle protection and it should work

Thanks for the very fast reply! I followed the guide to make passthrough work, but so far no luck. Additionally I wasn’t sure that passthrough is supported for BLHeli_S. Is It fully supported? Are there any quirks, like only working for some versions of BLHeli Suite?

Update: It seems that ESCs initialize if I connect the signal wires to the FC after the FC has done it’s bootsequence. This is of course great, because it means that I can continue working on the project. Yet it is still not optimal, since it is quite inconvenient to reach in and connect and disconnect the ESC wires. What can possibly be the cause of this issue?

Servers by jDrones