ESC won't work with Omnibus F4 Pro

I have an Hobbywing Platinum Pro v3 ESC that will not work with an Omnibus F4 Pro running Arduplane 3.9.4. I have calibrated the ESC using my receiver and turned off all arming checks and the arming required flag. In Mission Planner I can see that the receiver is sending a signal to the flight controller. I also see that the flight controller is sending an signal to the throttle output channel. But, the motor the ESC is hooked up to does not spin up when I move my throttle stick. I’ve verified that the motor and ESC work with my receiver. I’ve also verified that a signal is being sent to the throttle output channel by hooking up a servo to it. The servo moves when I move the throttle stick. I’ve tried a different Omnibus F4 Pro with the same firmware and have the same problem. Any suggestions?

amigo, buenos dias…
lo que puedes hacer es revisar tu coneccion desde la tarjeta de vuelo (que no este invertida)
tambien puedes verificar con tu multimetro que si este mandando señal conectando una puta de tu multimetro a tu esc en el negativo y otra en la señal (donde conectas el motor) y al momento de acelerar te daras cuenta del error.

1.-si al acelerar recibes voltaje en tu miltimetro probablemente tu falla este en tu motor.

revisa tu coneccion del motor al esc que si tengas bien colocado el de señal.

2.- si al acelerara no recibes voltaje en tu multimetro probablemente tu falla este en tu esc.

2.1.- revisa que tu esc este bien conectado a la toma de corriente.
2.2.-revisa que tu esc este bien conectado en la tarjeta de vuelo (que los cables no esten invertidos o que esten dentro de las salidas para los motores.

Espero haberte ayudado.

To be clear, both the motor and ESC work when I connect to my receiver. There is a signal on the output pin too, but the motor doesn’t spin when attached to the flight controller.

does your ESC initialize correctly when connected to your omnibus, usually indicated by cell count beeps + initialize tone?
as you‘ve calibrated your ESC on your RC Rx, it might be set to a throttle range different from the FC’s default throttle output.
you can check comparing your throttle channel‘s input and output values in MP‘s status tab.
if it does not initialize correctly, it might be required to recalibrate your ESC using your FC‘s throttle endpoints, or adjust your endpoints respectively using MP’s servo output tab or the full parameter list / tree.
see for reference.
attaching your currently used parameters will likely help.


Did all your suggestions. Had some success, but not there yet. Here’s the weird part. If I plug my FC into USB and then plug the battery in, the ESC “arms”. In other words, I get the cell count beep. The motor will spin up when the FC is armed. However, when I DO NOT plug the FC into the USB connected to my PC, but just plug the battery in, the ESC does not emit the cell count and the motor will not spin.

In a nutshell, if I apply 5 volts on the usb port then plug the battery in, the ESC will arm. I can then unplug the USB and the ESC is still armed. And yes, I have removed the diode as per the instructions on the Omnibus F4 Pro Ardupilot page. I did so in an attempt to fix this issue and because I want to power my servos from the ESC’s BEC. Without putting 5 volts on the USB port, the ESC won’t arm.

Here are my params

arduplane.param (17.2 KB)

params LGTM. interaction of USB / batt on thr signal is pretty unlikely, but some ESCs do have issues with the thr signal during FC bootup. by plugging USB first, you’d power ESC after boot and avoid this issue. so one more test i’d suggest would be:
unplug ESC signal wire from FC
power FC by batt only
connect ESC signal wire after bootup.

if it initializes correctly then, there likely is some boot-phase signal issue…

unplug ESC signal wire from FC
power FC by batt only
connect ESC signal wire after bootup.

This worked, the ESC initialized.

ok, thanks for testing. so imho it‘s most likely your ESC type having some sort of issue with what happens on the signal wire during boot phase. on a sidenote, i‘m using hobbywing escs with good results on various ardupilot FCs including omnibus, just not that exact type you‘re having trouble with.
maybe try ARMING_REQUIRED = 2 to set unarmed state to „no signal“ and check if you can get it to initialize correctly on arming with that setting.
apart from that, opting for a different type ESC would likely save some time and hair-pulling…

Try again if it works with slightly lower values for SERVO3_MIN/TRIM, because 982 µsecs measured at usb power supply need not match with 982 µsecs seconds at battery supply

Tried lowering SERVO3_MIN/TRIM and ARMING_REQUIRED = 2 . Didn’t help.

Switched out the ESC, had same issues. Took another Omnibus F4 Pro that had Arducopter on it and installed Arduplane on it. Behaved exactly the same. Both boards have the diode removed as per the instructions on the Ardupilot Omnibus F4 Pro web page. Both FCs areOmnibus F4 Pro v 3.

@sfugarino sorry, i can’t yet figure what the issue is based on the information provided. are you saying those ESCs do initialize correctly when you’re running arducopter but don’t when you run arduplane on that board?
could you provide a log maybe?


Solved. I used a HobbyWing Flyfun ESC and everything started working. The first ESC should have worked and I’d like to know why it didn’t. But for now, I can move on to other problems.

glad you got it working! so it seems it really was the hw platinum v3 not playing well with the signal handling.
just curiosity: what type was the second ESC you tried that didn‘t work too?

Another HobbyWing Flyfun 40 Amp ESC, but it was an Opto. More or less a brain cramp on my part. I had ARMING_REQUIRED set to 2. The ESC was beeping like it would if there was a safety switch and it hadn’t been pushed. I didn’t try to arm and just assumed it wasn’t working. So, I dug up a FlyFun with a BEC, and got the same results. This time I armed the FC using the rudder. The ESC initialized and the motor spun up. I wet back and set ARMING_REQUIRED to 1 and the ESC initializes without arming now. In short , the second ESC was working, but I misinterpreted the beeps,. The first still wont work. It works with a receiver or a servo tester. Just won’t work with the FC. I have no idea why. It’s actually the best ESC of the three.