ESC/Oneshot125 calibration problem in rc8

I have a quadcopter with a 3DR Pixhawk 1 and dys XS20A ESCs. It was running well on 3.4.6, with the ESC protocol set to Oneshot125. Prior to upgrading to 3.5 rc8 I ran through all the calibrations including ESC calibration which completed successfully. I did the upgrade to 3.5 rc8 and when I tried to run ESC calibration on 3.5 it failed. I click the button in MP to start, then power cycle the quad. The Pixhawk just sits there with rapidly flashing red/blue/green. I tried the procedure about ten times and the same thing happened each time. I then changed the ESC protocol from Oneshot125 to Normal, and ESC calibration now works fine. I also tried Oneshot, that doesn’t calibrate either.


hmm… we’ve had quite a few reports of the OneShot ESC calibration failing but I’d thought we’d gotten over all those issues, especially with the Pixhawk1.

You’re using AC3.5-rc8 (i.e. you’ve uploaded the beta very recently?). Also if you’re using BLHeli, any chance you know which version of BLHeli is on the ESCs?

Hi Randy. I updated from 3.4.6 to AC3.5-rc8 a couple of days ago, using the latest MP beta. I just checked the ESCs - they are all running 16.65. Let me know if there’s anything else I can do to help.