Esc-desync issue? Hobbywing Xrotor pro 60a & Tmotor P60


We have a lot of problems with the tune of our drone:

22inch prop
22ah 6s lipo
Esc hobbywing xrotor 60a (DEO off)
Tmotor P60 motors
Cube orange
copter 4.0.7

We have a lot of problems after the pid’s tuning. With a little wind, the drone starts to make a random dangerous behaviour like pitch back 50 degrees over the desired pitch angle. in the rest of the flight angles there is some random problems, also in Alt Hold and Loiter modes.

We suspect that the problem is a esc desync.
The DEO feature of our esc can improve these problems?
Can you suggest us some solution?

In another drone, we install different esc, the t-motor flame 60a and this problems dont appear. THe problem its we have various drones with the hobbywing esc and we try to solve this problem with pid’s tuning and parameters tune up to avoid the change of all hobbywing esc of these drones

we add the bin file of the last fligh with lot of problems

thanks very much

No reason to suspect desync but the tune is poor and it doesn’t look like you followed the Initial Parameter Setup in Mission Planner. Update to Latest stable Arducopter
Enable and use EKF3 not 2
Proceed with the Initial Parameter Setup.
Set ATC_ANG_PIT/RLL back to default (4.5)
Configure the Dynamic Notch Filter
Run Auto Tune.


Just crashed my quad with similar hw (p60 and xrotor 80a HV, 12 s setup).
Quad was ok after initial parameter setup but when I started autotune procedure on the yaw axis the drone started to wobble after a short time and I could not recover safely from it.
Not sure if desync or not but will check logs during the weekend.
Also noticed that other people using p60 and xrotor had similar issues.

All the best,