ESC Calibration

I tried Automatic ESC calibration and still won’t work. The manual ESC calibration worked perfectly but when I plugged everything back up, the ESCs wouldn’t respond and I got that same constant beep from my servos that I have always gotten except when doing the manual ESC calibration. Every component and part is from 3DR and I am using a DX-7 transmitter. I’m thinking the Power Distribution Board is the problem but I can’t be sure.

PLEASE give me any insight that you can. Thank You!

Btw, I am using the APM 2.5, and the most updated version of mission planner.


could it be that you use the wrong calibration method?

  • Switch everything off
  • power up transmitter in full throttle
  • power up copter (APM)
  • disconnect the power to the APM,
  • with the transmitter still on and full throttle, reconnect the power to the APM
    now the calibration process should start.
    Once done (3 beeps / 4 beeps, depending on the type of battery used) throttle down.
    One long beep
    Disconnect power on Copter and Transmitter
    Now it should work

make sure there are no safechecks failing when starting up.

OctoFly Hilversum

I am having difficulty getting my speed controls to work correctly
i have done the above process and can get some functionality

It appears to function on the second power up. the motors power on and off fine, but the lights are still flashing red-blue at the same rate as before. when I power down and reconnect, at low throttle, I get no responce. I do get a red flashing light, then it goes to red-blue quickly flasing, then red flashing again and finally to constant blue and red flashing (looks to be purple from the side).
What is wrong?
This is on a RCtimer S800 hexacopter. I have tried it many times and get the same result.



I figured out that my PDB and PM were the problem. I bought new ones and now everything works perfectly.

I’m not sure if this is the problem but I just thought I’d share my findings.