ESC Calibration X500 holybro


Just build the X500 kit made by holybro, I tried calibrating the 4 ESC’s at once using the throttle up method. Nothing is happening however. Any special method to do this? (I am a beginner). Should i switch off the arming check?

EDIT: I am using missionplanner and calibrated everything already. RC etc is working properly. When powering the drone, the motors move a tiny bit, which makes me think they are connected correctly as well

Do the motors run correctly when using Mission Planners Motor Test function?

Can I try it if the ESC’s are not callibated yet?

Sure you can. Props off, this just test operation, order and direction.

1 Like

The commands are denied by the autopilot.

ps: I cannot arm the drone. PreArm: Hardware safety switch. I tried pressing the button on the GPS module and it doesn’t seem to arm. Holding it longer gives another error: Check firmware or FRAME_CLASS

For now disable the switch. I never use a safety switch on a multirotor (personal preference) but you can re-enable it later if you want. Set BRD_SAFETYENABLE to 0.

But, it should function. Post your parameter file.

Changed the BRD_SAFETYENABLE to 0. Still the same error unfortunately. GPS is double blinking yellow

Parameter.param (17.8 KB)

You didn’t configure a FRAME_TYPE. No motors are assigned to outputs. Select 1 as the FRAME_TYPE then re-start (power cycle) and try the Motor Test again. And make sure they are running in the proper order and direction:

And don’t even think about flying that craft until the Initial Tuning Parameters are set. Use the Tuning plug-in in Mission Planner (Alt>A)

1 Like

Thanks a lot. It did help, yet the problem is not solved. During the ESC callibration, the sequence ended with 8 low fequency beeps (which makes me think it wasn’t succesful). Tried using low throttle to power the motors which worked. The motor
test however doesn’t seem to work. Beeps are coming you of the system, yet no motor movement (even at 20%)

edit: it did exaclty this, so i guess it is succesful

It has to work in Motor Test or something else is wrong. And you would be better off with BLHeli_32 ESC’s.

1 Like

Everything is up and running now. Thanks a lot for the help!!

1 Like