ESC calibration and motor test issue

I was working on the pixhawk 2.4.8. Last week I uploaded the firmware on the Pixhawk and I did the ESC calibration using the steps in the mission planner.


But now due to some issues, I reuploaded the firmware into the Pixhawk but now I am getting an issue in the ESC calibration. The ESCs are not going into the calibration mode although the Pixhawk gives its RGB lights blinking during the process. I don’t know whats wrong with that as I have tested every thing and nothing worked for me. Kindly help me to solve this issue of calibration. I even tried the motor test and it also didnt worked.

Obviously that has to work before you can calibrate the ESC’s. A configuration error possibly if it worked before flashing the firmware again. Why did you do that?

One more proof that downgrading is almost always a bad idea.

Can you explain why you did that?
Did you make a parameter backup before updating?
Have you uploaded the backup after downloading? Uploading old parameters is only necessary when downgrading.

The problem has been solved. There was an issue in the calibration the frame type wasn’t selected properly. After selecting the propper frame type it worked.